Bome to GMA2 Temp Buttons Not Working

APC40_MA2.bmtp (9.1 KB)

I’m mapping some exec. buttons to an APC 40, and my temp and toggles buttons won’t work properly. The exec. will come on but won’t turn off.

Project file is attached.

This should work

First of all I set up an init preset to put your APC40 into Mode 2 where all buttons are momentary.

I created a preset to send the mode settings to the APC40 when the project starts. Make sure the APC40 is turned on when you start the project. I’m testing with a MKII so I disabled the MKII translator. I also set it to send the mode message when the port comes online. All of this is done in the translators of the Init preset.

I show two ways of handling this. Method one uses two translators and Method 2 uses 1 translator. Although the rules of Method 2 seem a bit daunting, I prefer this method as I like less translators so I disabled the 2 translators for methond 1. Take your pick on what you want to do.

Method 2 handles both a note-on and note off message which is why your setting were broken because you were only looking for note on.

Here are the commented rules for method 2

// check for note message  0x80 or 128 Compare with 0xe0 to determine this
// not a note message
if rr!=128 then exit rules, skip Outgoing Action

// look for 128 (note on)or 144 (note off)
// and set the value as 127 or 0

if rr==144 then qq=127

output is oo 35 qq 35 hex is 53 decimal

I also set up aliases as they are easier to understand in MT Pro. You may need to assign them to your physical ports the first time you open the project. Since I don’t have an APC40 MK1. This is how I set mine up for testing. You can change your assignment in the MIDI Menu → Edit Project Port Aliases.

APC40_MA2-sjc.bmtp (10.7 KB)

Let me know how it goes.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: