Can Bomebox default to my own MIDI routes?

Hi all,
just joined the bandwagon of bomebox users. I have to say I’m pretty impressed with the ease of use out of the box, the ability to connect everything as I wanted in my setup, this is quite cool.
As of now my boomebox is connected through Ethernet and it works great.
I wanted to know if there was an easy way to tell my bomebox to get back to my customised route set after reboot. As of now, I get an empty set of routes after each reboot (I unticked the default any to any routes, as it’s annoying), which is a bit of a hassle, because I have to log into the bomebox, select and load my personal route set for everything to work as I want. Any kind of box to tick somewhere so I can say “please load these as my default routes” ?

Does that require MT Pro ? I think I’ll ultimately need this to filter out some stuff that happen on my MIDI network anyway, but I have to say, it feels pretty daunting using the trial for now. I’m wondering how to find my physical devices in there, and configure something which is suitable in a standalone mode inside my Bomebox. But I may need to read the manual a little more.

Thanks in advance.

Knarf Sondiers
from Les Sondiers Youtube channel (FR)

Hi, and welcome to the Bome Forum!

After you create a routing you like, save it as a route set. Then select that route set. BomeBox should then remember that route set after a power cycle unless there is a MT Pro project file that is loaded and running. The MT Pro project file will always override any existing static route set when it is loaded and running.

You will need to purchase an MT Pro license if you want to use advanced translation features. The trial version will not work on BomeBox as it doesn’t sign the file and BomeBox requires signed project files to run.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi Steve, thanks for your answer. I can confirm I have previously created a route set and saved it, this is the one I would like to be loaded by default, but it does not behave as you described. After each power cycle, I have an empty route list, and I have to manually reselect my previously loaded route set for it to work again. This is pretty annoying.
I can also confirm I have no MT Pro project loaded or running.

Could you check your version of BomeBox Firmware and if not the latest, please upgrade?
If it is the latest and you are still having an issue, then let me know.

BomeBox Firmware 1.4.2

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi again,
First thing I checked, and 1.4.2 is the one I have.
Thanks.

OK, let me check into it further then. Thanks for letting us know!

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

OK, I’m not able to reproduce the problem. Make sure that you don’t have a project file loaded as it will override any set static midi routes. Also make sure you uncheck set everything to everything. Also when you create your new route set, save it then make sure it is selected before you power down.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi Steve,
don’t know what to say.
Here is a screenshot of my bomebox web config home screen after turning it on this morning.

More screenshots, of my MIDI routes after reboot.
And then I have to select my “KNARF LIVE” route set and load it.
If I reboot, I’m back to nil.

Very Strange.

Could I see your devices pages?

Sure.

And the rest of it

Thanks, I’ll do some more testing to see if I can reproduce the issue. Maybe it has something to do with alias assignment and the availability of the assigned USB or network ports? I’ll get back to you.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Sounds like a plan ! Thank you.

Hi,
I still have not been able to replicate the issue so here are a few things to try.

  1. When setting up route sets, set them up to route to real MIDI ports and not aliases. I’m not sure if you are using aliases but I’m theorizing you might be).

Aliases can only be created in a MT Project file but are remembered by BomeBox after they are created and assigned by you on the BomeBox. It is possible that some of the aliases were remembered incorrectly which may cause the issue. This is just a possible theory I’m exploring.

  1. Try re-installing Bomebox Firmware.

If this doesn’t work, I think the best thing to do is set up and load a project file with the static routing you want and have that one set up on your BomeBox. If you don’t have Pro Version, I can send you a project file that you could use if you show me the routing you want.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi Steve,
I’ll try and let you know.
Thanks for the time spent on this topic, very much appreciated :grin:

Not sure if that’s of any help, but I did try to route to real MIDI ports, saved my route set like this, but it didn’t work either after reboot. No MIDI routes.

I then deleted my route set, ticked the “Automatic routes” box and rebooted (tried twice with software and hardware reboot). I got no midi routes after reboot, even the automatic ones were not present.

I’ll try to reinstall the bomebox firmware…

Very Strange. Hopefully re-installing firmware will fix it. Also please clear your browser cache in case it is indeed working but you are only seeing a cached version of your route status. If you select private browsing, it will not use the browser cache.

Steve

Victory!

So. Here’s what I did to solve the issue.

  1. Reinstall of the firmware (through Settings / Backup & Firmware)
  2. Reset to Factory Defaults (the red “Perform Reset” button in the same area)
  3. Basic reconfiguration (password, wifi, etc.)
  4. Reconfiguration of my routes through a new route set.
  5. Test of my MIDI config : success !
  6. Reboot.

And voila! My previously enabled customised route set is still there after reboot.

:partying_face: :champagne:

Awesome!

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like