Feature Request: Incoming - Port xx Activity > Outgoing xx

Not sure if it can be done as I have zero knowledge of how BMTP works. But it would be really swell if we could use port activity to activate/deactivate Presets.
Use Case:
I activate a Preset with a key stroke or my Launch Pad. Now, when I press any note on my Roland piano, BMTP activates/deactivates Presets.
I press any pad on any number of MIDI devices, BMTP activates/deactivates Presets.

By the way, I really appreciate the ‘App focus’ feature in the lates update. GOLD!

Hi, the following should do what you want.

We look for either 1 byte, 2 byte or 3 byte messages coming from the target controller. When we see any of these messages types we set a one shot timer called “MIDI Active”.
The outgoing action for the “MIDI Active” timer is to send a note-on back to the controller to light the LED.
When we set MIDI active, we also set a delayed (Watchdog) timer with a delay of 100 ms. If there is no activity within that time, we send a note-off message.

The only thing it will not work on is SysEx messages unless you include translators with the specific SysEx patterns that match.

MIDI-Active-2021-09-22.bmtp (1.6 KB)

In my case I’m just turning a note-on or note-off but you could set different outgoing actions to do anything that Bome MIDI Translator supports.

Thanks for the good words on Bome MIDI Translator Pro. Yes I found 1.9 to have quite a few useful new features.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Thanks for that Steven!. Works perfectly! Now my Roland Piano can activate/deactivate Presets when I press any of the 87 keys.

Except, now when I have the Preset with these Translators active, Cubase is not receiving note information from the Roland. And the globals you set seem to be conflicting with my project i.e none of the LEDs on my Launch Pads are working.

Thanks again.

1 Like

Never seen an 87 key keyboard.

Roland FP 10
Sorry, just recounted 88.

So I set the 3 bits Translator you set up to the Roland port but now the Roland does not seem to be inputting notes when that Preset is active. Any ideas why?.

As it stands, I must say that, although your workaround was a potential solution, my feature request would take a lot of the complicating factors out of this for people with a large and complex pre existing projects that use many global variables. :slight_smile:

Look and see if:

  1. You have a MIDI thru path set to your target device (I didn’t in the sample I sent you).
  2. If you want the MIDI message to also go through you need to remove the “Swallow” option on the translator.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

I have the Roland port set to BMTP virtual out. But Cubase still is not receiving note info. :frowning:


Any solution for the globals issue. I have not delved into the world of globals yet, I just use the ones you set up for me at this point.

Also I set up aliases for the project file I sent you which is always a good idea in case you move things around.

My Controller → Application

Where My Controller is you Roland and Application is the virtual port to your DAW.


Okay, I just unchecked the swallow thing and now Cubase is receiving the note info. Thanks.



Global Issue. :frowning:

Here are the globals you set up for me. Can you please tell me how to alter the new ones so that they don’t conflict with these?. Cheers
Globals.bmtp (2.4 KB)

Okay! everything seems to be up and running. The globals don’t seem to be conflicting know :thinking: Thanks heaps for the help. :smiley:

Yes, I don’t think I used any globals in the MIDI activity project so there should not be any conflicts.