Is there a way to force quit MIDI Translator

Now and again I get an error that causes MIDI Translator to be unresponsive to inputs and thus to not output any MIDI either. Sometimes this happens in response to a "midi engine overrun". Actually I'm not sure of the exact message but it's something like that. There are other causes as well.

Sometimes, I'm able to quit MT and restart it. I can then continue with my set. Sometimes, I need to invoke the task manager and End Task (for MIDI Translator) in the Apps section of the manager. But sometimes, even though I've used End Task, it turns out that there's still a MIDI Translator shown in the task manager under "Background processes". I'm unable to use End Task to quit this process, and if I merely try to start MT again, this process interferes. I get messages telling me that MT can't open the ports I use because they're already in use.

Is there a way to force the background process to quit? Otherwise I have to restart my computer, which obviously stops my set dead - cold.



Hi Gabriel,
There is probably something hung in the Windows MIDI Driver. Have you tried unplugging and re-plugging in your MIDI controllers to see if that helps?


Hi Steve,
Yes, I’ve tried unplugging and replugging the controllers, but the “ghost” Bome MIDI Translator in the Task Manager Background Processes is persistent. Can’t make it quite, even though there’s not a Bome MIDI Translator showing in the Apps section of the Task Manager.
I wonder if a Mac would be more forgiving for this and other aberrant behavior I sometimes have with Live and BMT. It might be worth a try. I think Apple allows a person to buy a computer and return it if you’re not happy with it. The investment would be substantial, since I need plenty of processor speed, and I’d have to find a model with at least two USB ports and firewire (or a display port).
For now, though, I was hoping you might know a way to kill the persistent Background Process.

I know of no other way. I’ll see if Florian knows.

Sorry, I have to agree with Steve. It’s most likely that a MIDI driver got hung, freezing MT Pro with it.
MT Pro itself does not do anything which is so low level that it could cause the task manager to not be able to kill it anymore.