Keystroke Output Has Stopped

I have the latest build for MTP. I'm using it on a Mac running system 10.14.4. I have been using it for a couple of years to advance the "slides" in Propresenter (6.4). MIDI notes set up in Ableton Live (9.7.7) go from the computer hosting Ableton via Apple Network MIDI to the computer hosting ProPresenter. This system as been working flawlessly since it was set up…until it stopped working. Unfortunately, I wasn't informed right away that it had quit working. One of the operators just happens to say it hasn't been work "for a little while." So it is difficult to trace back what has changed system-wise. According to the Log, the keystroke output is going out, but Propresenter doesn't respond. I opened Text Editor to see if it would see the keystrokes, and apparently, it doesn't either. I am wondering if the color of the LED in MTP Event Monitor is any sort of indicator of a problem. The Keystroke Out indicator lights red. I would appreciate any help anyone can give. I am attaching the file I've been using that has worked for so long. Again, MTP Log indicates it is receiving the MIDI and sending the Keystroke, but the any active app "up front" doesn't indicate that it is receiving a keystroke. I've also checked and unchecked the "Suppress Outgoing keystrokes when focused", and that changes nothing.



Please go to your security and privacy settings on your Mac and ensure MIDI Translator Pro is checked. See attached screen shot.



I tested the first 3 translators of your project (changing the input trigger), and they worked flawlessly on my Mac running Mojave (10.14.4)
I had my output set to a text window in the Cot editor.
Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist

Thank you very much! It worked. Such a simple answer. I’ve had to do this before for another app and completely forgot about this. Thank you, again!

My pleasure. Glad you got it working!

Could you please mark this thread as resolved? Thanks!