MIDI Translator Pro 1.8.4 Won't Open on iMac 10.13


Running into a strange issue. I'm unable to get MIDI Translator Pro to show on my iMac. Clicking on the icon in the Dock makes it bounce for about a minute. Then it stops, and I see nothing.

However, in my Activity Monitor app it says that MIDI Translator Pro is open and running, and if I go to the Force Quit applications menu I see it listed. But, in the Dock, there's no dot under the icon to indicate that it's running, and no interface shows up.

Prompt help on this would be much appreciated. I have four Christmas Eve gigs and need MIDI Translator Pro at them all!



Maybe it is set up to start minimized? Did you try double clicking on the icon in the menu tray? If this doesn’t work, you should be able to use finder to go to your library folder. Under that you will find

Applications/Bome/Bome MIDI Translator Pro.bmts

If you delete that file and the backup files, it should come back with normal project defaults (not minimized).

If that doesn’t work. Try re-installing MT Pro.

Let me know


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist


Hey Steve,

Thanks so much for the reply.

Unfortunately none of these options worked. I had previously deleted all .bmts based on looking on the forums here and that didn’t do it. There is the possibility it was set to start minimized, but at this point with those files gone that doesn’t seem to be the answer.

Tried reinstalling several times with the same result.


Maybe the project file you are using has a problem. Try just double clicking on a different project file in Finder and see if things clear up that way. When you open MT Pro with the Launcher it will always try and use the last project file you had opened.

Hey Steve. Thanks for your reply. I tried opening with different projects to no avail. Fortunately the computer I use MIDI Translator Pro on has a specific use, so it’s not full of files.

I ended up just wiping the hard drive and reinstalling macOS to get it to work. It seems to work now. Thanks for your help!

Wow pretty drastic but I’m glad you got it working!