Note off -

Sometimes ,the PC "lost" Note off received from keyboard,and the note sound until I touch the specific key to stop the sound. all MIDI controlers are "swallow" in my project(not direct midi IN) .I need to execute key off in cascade (2-3 key off on distance 2-3 ms ...or....whatever distance between signals after receive Note off from keyboard ) . This is the only bug I have in my project....Thanks

Could you post your project file? I all have a look. Keep in mind that Swallow is only valid if the outgoing action is executed OR there is no outgoing action, so it may be possible that if you are using execute rules, skip outgoing action, that an unwanted note-on is still getting through if you have a MIDI thru path set in your MIDI router section.
In either case, you can cascade through all of the notes on your keyboard to force note-off using a timer. I can post an example if that is what you want.
Bome Q and A Moderator and
Independent Bome Consultant/Specialist

mm…I have the switcher in Bome …to enable/disable specific VSTi . If I press a note,and change the program(and the note is still pressed),the specific note will never stop until I come back and activate switcher and hit again last note to stop the note. I think I need a script to hit “note off” when switcher disable the specific VSTi ….

Since you might be in process of hitting various notes when activating the switcher, it is probably better to send an “all-notes off” CC message. Most controllers understand CC all notes off but if they don’t, there is a way with a timer to cascade through each note sending off messages.

The CC number for all notes off is 125 with value of 0. Try that and if that doesn’t work, see the attached example which will iterate through all channels and all notes turning them off one at a time.

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist