Roland GR-1 & SysEx data rate

I'm trying to use SendSX to send SysEx to my old Roland GR-1.


For some reason SendSX always results in garbled data, even on the slowest data rate setting, although the same file is sent without issues from MIDI-OX. My MIDI-OX settings are 90 milliseconds between buffers.


Is there any chance that BomeSX minimum data rate is still too fast for older equipment like the GR-1?


If this is the case, would it be possible in future updates to allow slowing the data rate from SendFX even further than 313 bytes per second?


Would definitely prefer using SendFX if possible, it's a much easier interface to use.


Thanks for your time



Maybe data rate is not the issue and it is buffer size instead. Have you tried splitting the long messages? Can you show an example of a message that you are sending.  I use SendSX with my Roland FC-300 without any problems and those are probably about as old as the GR-1. 

313 bytes/sec is pretty slow even in MIDI terms. Is there any other device connected to your GR-1 that might also be sending at the same time (perhaps going to a thru port)?  Do you have the GR-1 output set up to go back to your computer? If so maybe there is a MIDI loop happening here.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist


Also, what type of interface cable are you using? Some cheap USB to DIN intefaces have extremly small buffer sizes. Try the Roland UM1 or the iConnectivity MIO1. Most users report good results with those.

Hi Steve, thanks for your reply...

I'm going in & out of a Behringer 1820, although seem to have similar settings in both MIDI OX and SendSX (no midi thru selected). I have 'split long messages when sending' enabled.

It's very strange as MIDI OX works fine sending right after trying SendSX. It's pretty repeatable. Maybe it's something to do with my system, but I guess I'll stick with MIDI OX for now...but SendSX is just way more intuitive and simpler. MIDI OX is a bit of a convoluted 'guess the menu' situation.

Thanks for your time, will check future versions


I've attached a sample file, it's just the default setup with a single character in the first patch changed (from Rhodes to Qhodes). Very strange, I just tried from reaper and was successful as well. I'm totally not intending to disparage SendFX because it would be far cleaner solution than Reaper or MIDI-OX. There's something with my system that doesn't like SendFX for whatever reason but will keep investigating...thanks for your time regardless


OK, we will look into it for future versions.

Hello Steve (or whoever is interested)…

I saw that there is a new update to some software…was wondering if there was any thought to allowing more control over slowing the data transfer rate in a future version of SendSX?

thanks W

Hi @wiser12345 ,
thanks for asking. At this point, we don’t have any plans for updating Send SX… Have you tried without “split long lines”? Also, don’t split on loading (setting below the throttling settings)?
Sometimes, the non-intuitive solution works!