Switching MIDI Channel using Bome MIDI Translator Pro Keyboard keys don't work

Hi, I downloaded the Dynamically Switching MIDI Channel using Bome MIDI Translator Pro Keyboard keys template(https://www.youtube.com/watch?v=XkiWH8fOBNY&t=61s&index=31&list=PLzwHsH6-VZ8Qy_dxsf0LqorjarvnDIFiy) to change the MIDI channels using the A and S key( up and down).

I followed the instruction and allowed the software to take control in the security panel within the Mac OS.

When I push the physical keys on my keyboard there is nothing happening, have the LOG window up, there are no changes.

I even put a hard wired keyboard , still doesn't do anything.Is there a setting that I missed?

I downloaded the template and didn't change anything on them, technically the hard keys should do the work..Any idea why it doesn't work?


Make sure that your active Window is NOT Bome MIDI Translator, or set the options so that it will allow keystrokes when focused.

Regarding of allowing software to take control of the security panel, I’m not sure because I’m on Windows, not Mac. However if I remember correctly, MT Pro should not need to have or should not have any special security (Admin) privileges. Having Admin privileges on Windows platform will break things so maybe the same is true with OS/X.


Another thing to look at, since the project in the tutorial was created on a Windows PC, there may be some differences in the project file between PC and Mac as Mac handles keystrokes differently. I suggest you change the incoming keystrokes and then change them back. Then save the file and restart it. That might clear up the issue.

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist