A couple questions about Bome Network

I have a couple of synths that have their own VST editor.
Each synth that isn’t used in a session is turned off for power saving reasons, but most of those editors don’t like it when their assigned MIDI ports are suddenly unplugged or unavailable.
Add to that the whole windows midi port assignment of multiple identical devices and it becomes a mess when loading templates.

So, to keep my sanity, I would like to connect those synths to a BomeBox and access them over the network with a static list of virtual/remote ports.

Is it possible to set this up in a way that those virtual/remote ports are always available even when the assigned device is unplugged, so that windows can always open them even if they’re dead-ended?

If so, how do I set this up?
And what license would I need for Bome Network to make this happen, is it the just the Unlimited named ports or also the Pro license?


With BomeBox you will see Remote MIDI Ports on your computer but only when the devices are plugged in.

However, maybe you can also get “Unlimited Virtual MIDI Ports” as an add-on to Bome Network Pro and then have your DAW’s talk to these ports instead. Then set up the Bome Network router to route the virtual ports to the Remote MIDI Direct Ports. Of course if they are not connected, the routing will not complete, but the Computer would still see the Virtual Ports and be able to open them although the are routing to nothing.

Say if your synth is seen on BomeBox as “MySynth” and the BomeBox is named “MyBomeBox”.

On your computer it would see Remote MIDI direct port a “MyBomeBox:MySynth”

Then you create a virtual with Bome Network on your PC named
“MySynth” and the a routing as:

IN: MySynth Virtual In - > OUT: MyBomeBox:MySynth

Now the port MySynth should always be seen on your computer whether it is attached to your BomeBox or not.

Make sense?

You would need Bome Network Pro, with the “Unlimited Virtual MIDI Port” addon to accomplish this.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz
1 Like

Thanks for the quick reply.
I think your solution would stop the plugins and FL Studio from bothering me when loading templates.

What happens with those remote ports when, for instance, the BomeBox is unplugged?
Does windows see all those ports being unplugged, or just Bome Network?
Ideally the windows midi system wouldn’t notice anything because FL Studio sometimes crashes when rediscovering the midi ports.

Also, what happens with identical devices when everything is plugged in again?
I know BomeBox can keep them apart, but what about windows?

Do I have to set up Bome Network with static IP adresses?

I don’t know if the BomeBoxes are supposed to be auto-detected, but I can’t connect to anything without manually entering the IP adress.
The BomeBox is on the same subnet.

The network connection is OK, I can connect to the web interface no problem.

It’s also not clear to me why I would need the Bome Network Pro license, since I’m not connecting to other computers or an iPad. This is from the shop:
“Note: MIDI connections to the BomeBox also work without the Pro license.”

No, as long as they are on the same network the should be self discoverable. If you have more thane one BomeBox then one of your BomeBoxes needs to be DHCP master and the others set up as clients. If they are standalone. If you are running of a different router that is a DHCP master, then everything else should both be set to a client.

If your network has both WiFi and ethernet to your BomeBox then disable WiFi. Your BomeBox should only have one network path otherwise your BomeBox will appear two devices on your network with the same name as your BomeBox and will confuse things.

[quote=“DreamXcape, post:4, topic:4054”]
It’s also not clear to me why I would need the Bome Network Pro license, since I’m not connecting to other computers or an iPad.

True, but in your case you are also using “Unlimited Virtual MIDI Ports” addon and I believe this addon is only available for Bome Network Pro but I’m not 100% sure. Buy
“Unlimited Virtual MIDI Ports” first and if you cannot enter the license key, then you will need also Bome Network Pro. I have both so not sure if standard free Bome Network works with this option.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

The auto detect doesn’t seem to work for me. I know I’ve seen it working in the past, but then I had everything setup with my router assigning static IP’s based on MAC adresses.

At the moment, my router is set to DHCP handing out automatic IP’s.

There is WiFi in my setup, but the BomeBox WiFi is disabled.

edit: I also checked the firewall inbound rules, those are setup ok.

I understand, will try this out.

Tried rebooting, rebooting the BomeBox, restarting Bome Network.
No detection of any kind.

The latest install of Bome Network also deleted my start menu shortcuts, the shortcut folder for Bome Network is empty.
Now I have to run it from the Program Files folder.

Honestly, this is not a good experience so far…

Manually entering the IP adress doesn’t work either.
Both Bome Network and the BomeBox web interface tell me they can’t connect.
When manually entering a host IP on the BomeBox I get this:
Cannot add manual IP/host. Maybe it is already listed or it is part of the directly connected networks.

It doesn’t make any sense to me because I can reach the BomeBox from the same system through the web interface. The BomeBox itself works as it should, except network midi.

edit 2:
Removing the one automatically added virtual midi port can’t be undone, Bome Network now asks for a license when trying to add it back.
A reinstall of Bome Network did not resolve this.

Any troubleshooting steps would be appreciated.


In the advanced configuration of the BomeBox (status > realtime graphs > active connections), there are always 3 connections besides the background connections for time etc.

The first one, from the IP of my pc, coming in at port 80 for the web interface.
And then 2 connections to port 37000 and 37777, also from my pc.
The destination for the last 2 seems to be an invalid IP ending in 255.

When monitoring network traffic from my pc, BomeNet.exe also points to this adress ending in 255.
There seems to be no network traffic going from Bome Network to the actual BomeBox IP.

Update 2:

When I manually enter the BomeBox IP in Bom Network, the expected connection from my pc shows up in the active connections on the BomeBox. In Bome Network I get the usual cannot connect and when I click keep trying it shows pending(off or not reachable).

Update 3:

The start menu icon showed up after another reboot, so probably a windows glitch.


I’m sorry you are still having issues! This is not the norm so something else may be in play here.

I would not recommend going into the advanced setting of your BomeBox as this can definitely break thinks if you aren’t 100% sure of what you are doing.

You will not be able to connect between two computers if you do not have Bome Network Pro, however you should be able to connect between a computer and Bome Network.

Here are the steps I recommend for you to get this all working.

  1. Do a network reset of your BomeBox. This should clear anything you did in the advanced settings and set your BomeBox network back to the factory defaults.
  2. See if autodiscovery works. If not, temporarily turn of you firewall to see it fixes it. Note if you have more than one computer, you should still discover them but not connect to them unless you have Bome Network Pro.

255 is a Broadcast IP address used for discovery. In your configuration it looks like discovery being handled on ports 37000 an 37777. The reason I ask to temporarily disable the fire wall is in case it is blocking these ports.

Do not use manual IP connecting. It is only used when you want to connect to a BomeBox on a different network address and your router will need to have a route set to tell them how to get to the other network…

If the BomeBox shows discoverable but not connected, and you are trying to connect via PC, then you still may need to pair the devices. On your BomenBox click the globe icon to open the BomeBox web page. Go to the network midi page and click connect on your BomeBox to your discovered computer. Then acknowledge the connection on your computer and also click "Auto Accept Network Connection request , so that you do not have to go through this pairing process again. See screenshots.

If nothing is working and you can get to the BomeBox web page. Please take a snapshot of your BomeBox setting “ethernet” and “wifi” pages.
Here are how mine are currently set.

Also, please let me know the IP address of your computer.

In the DOS Prompt type

ipconfig -all

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz
1 Like

I didn’t touch any settings, I was just looking for logs or any information that could help me troubleshoot.

That seems like a good idea, I’ve had this BomeBox for a while.
How do I do this?

Auto discovery doesn’t work.
The rules are in the firewall:
Turning it off didn’t change anything.

Got it.

BomeBox network midi page shows:
No Network MIDI device found.

image (dynamically assigned from my router’s DHCP server)
Router/gateway is

Found the network reset thing and downloaded the file.
Does the BomeBox care if there are other files on the USB drive?
Is any specific formatting needed?

Totally forgot, I have another BomeBox that is completely untouched.
I will try that one too.

Similar to this tutorial on password reset but with a different file name.

Or look at page 28 of the BomeBox Instructions.

Hi, I had a firewall issue with another product about 3 months ago. It turned out that I had 2 firewalls running (McAFee and Windows).
I didn 't know it so when I turned of MCafee things still didn’t work so I had to actually also turn off the Windows Firewall to get things to work. Maybe check that.

It appears that your network settings appear correct.

That should help in the troubleshooting process.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

There is definitely no other firewall installed.

I tried the other BomeBox, it’s a couple weeks old and came with firmware 1.4.2.
Never used except for powering on to see if it works.

Same results.

Did the network reset, no changes.

How do I see if the network reset file did anything?

Bome Network creates log files. It would be great if you could send them to me or post them.

It is the file BomeNet.log in the system temp folder, which you can find here:

Please open a Windows Explorer. Then in the address bar, type %TEMP% and hit ENTER.

In Finder, select “Go to…” from the Go menu, then enter /tmp .

Locate the file “BomeNet.log” and send it to me. If there is “BomeNet1.log”, please include it, too.

The log files will hopefully give us a clue what is happening.

Thank you very much! I appreciate your help a lot.

Also, please update your BomeBox Firmware to 1.5 as Firmware 1.4.2 will not support Remote MIDI Direct Ports.

Instructions for how to do that are on the link provided above as well as in this tutorial.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

The 1.4.2 firmware is on the new BomeBox, the old one(the one I did the network reset on) is updated to 1.5.

Hi, thanks for the log. On Bome Network tool in Network settings. Change Network Port from 37777 to 37000.

It appears from the log file that your computer is monitoring the wrong network discovery UDP port.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz
1 Like

That did it! BomeBox popped up in Bome Network instantly.
I guess that port setting was taken over from an older installation of Bome Network, when I clicked on default it went back to 37000.

It’s now connected and showing up in the midi router.

Thanks Steve!

You are welcome. And I confirmed that Bome Network Pro is not required for using Unlimited Virtual MIDI Ports if you just want to connect between BomeBox’s and Computers.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz
1 Like