Allen & Heath Failover Script Automatic Bome Box

Hello, we have the following problem. We are currently testing the Allen & Heath Failover Midi clock preset with 2 computers running Ableton. When computer A is running, computer B cannot send MIDI signals (e.g. scene recalls) to the Dlive. The preset works wonderfully if midi clock is not sent on computer A or stops. The preset jumps to computer B. But unfortunately you can still send midi signals from computer A when computer B is running and that is not allowed. The problem is, we saw in the Midi routing that Computer A always wants to automatically connect to the Allen & Heath mixer. Even if we deselect it, it always comes back. Is there an explanation why it always wants to connect automatically? We want either A or B.


What mode are you using? Manual or Timing Clock? Based on your questions, I assume timing clock.

This is as designed. We do no want Computer B messages if A is selected.

I have not been able to duplicate this behavior. MIDI IN still comes into the project but is not passed through to the A&H device.

If you are deselecting it, you must be running in Manual Mode . You must use either manual mode (preset 3 only) or timing clock mode (preset 5 only) but not both. Timing clock mode is described below:

  • If Both Computer A and B are sending clock, then the last selected computer will remain selected.
  • If A is sending and B is not, then A is selected
  • If B is sending and A is not, then B is selected
  • If neither are sending, it will cycle between A and B while it is searching for timing clock. I this case all MIDI messages come through from the currently selected computer during the search process.

If you want no MIDI messages to come through during the timing clock search process, then the project will need to be modified to disable both routes until if determines which one to enable. Modifying this script for that is beyond the scope of free support. If this is needed, we will need modify the project to wait until timing clock is preset for a period of time before actually enabling a given MIDI path instead of enabling each path during the search process.

Is this the issue that you are seeing? Timing clock mode allowing MIDI through during the search process?

To ensure we are both talking about the same project file. I’m including a copy here.

Allen-and-Heath-FailoverTiming-Clock.bmtp (8.4 KB)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hello, thanks for the information. We mean exactly this project file. All is well. It’s actually a likely bug in the Bome Box. We deactivated Auto Routing and removed all AutoRouting check marks before activating the script. But the auto route connection ‘Allen & Heath to Computer A’ and back kept reactivating automatically without us doing anything. That’s why the script didn’t work properly. And we don’t know why the AutoRoute connection keeps reactivating itself even if we keep deactivating the check mark.

Hi, what version of firmware are you running on BomeBox? Also if there are any MIDI routes set up in the project file, they will override any manual routing that you did outside of the project file. The routes should, however enable and disable normally.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: