Arturia Keylab MK2 - Notes not passing

Hello and a Happy New Year to everyone!

Using Midi Translator Pro with Arturia’s Keylab MK2.

I’m succesfully passing midi CCs and translate them using the software. However, At the same time, no notes are coming out of the keyboard! In order to have them play, I have to use Midi Thru from Bome to Arturia.

This thing is not happening when I use my Komplete Kontrol MK2, so here’s my question:

When using the translator, ALL events coming from the keyboard are supposed to be processed there? Or if I don’t have a rule for a control (e.g. a note key) this event should pass to my DAW and not be shallowed?

Here are my settings:

Inside Midi Translator Pro I have,
MIDI Input: Arturia Keylab 1 (Keylab 2 is reserved for Arturia’s commands)
MIDI Output: BOME MIDI Translator 1 Virtual out

In Cubase I have set Midi Input for each track to ALL Midi Inputs.

Any help will be really appreciated, thank you!

Hi and welcome to the forum!

The way MIDI thru works everything passes from the thru input to output if.

  1. There are no translators to override the thru path
  2. There are translators but the “swallow” option is not set
  3. There are translators but they do not execute their outgoing action

Any time you have a translator, it will override the thru path if:

  1. Then input and output ports are the same as the thru path
  2. The translator has swallow set for that given incoming trigger
  3. The output of the translator is executed or is None and “swallow is set”

So if you want all Korg controls to pass thru, draw a line from input Korg to Bome MIDI Translator 1
For your Arturia, draw a line between Arturia and BMT 1. Then override any things you don’t want to pass through by setting up translators of your choice or output of none with swallow set.

A generic rule to stop all 3 byte messages from passing through would be

incoming: oo pp qq
Outgoing: NONE
Options : Swallow
For the translate or parent preset define the input as Arturia and output as Bome Virtual Port 1. This would be required so that it doesn’t also suppress MIDI coming from your Korg.

I’m happy to look at your project file and advise further if you post it.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hello and thank you for all this info!
However, I still cannot understand how Komplete Kontrol is sending notes to my DAW WITHOUT setting it to the “thru” settings.
I attach screenshots, of my default midi settings, and the two individual for Komplete Kontrol and Arturia. As you can see, I set Arturia to MIDI THRU, otherwise I get no notes in my DAW. At the same time, I don’t set Komplete Kontrol to MIDI THRU, and still it sends notes! It just puzzles me.

Could you post your project file. This is an incomplete picture.

Depending on how you wrote your translators you could be:

  1. Blocking message from going to a MIDI THRU path by having swallow set on
  2. Enabling message to go through MIDI THRU path by either.
    • Not having swallow set
    • Having a rule like “exit rules, skip outgoing action” which still allows the thru path.

The port input and outputs at the pre-set level only affect the translators within that preset and only override the thru paths if they have the same input and output of a given thru path at the project level.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hello, I attach a very small project containing two presets, one for Arturia’s Keylab and the other for Native Instruments Komplete Kontrol.
Nothing special about it, in fact it’s just to show my midi settings.
As you’ll see I have a MIDI THRU between BOME and Keylab, BUT I have no THRU set between Komplete Kontrol and BOME!
Now, this way, everything is working great! Ι’m just puzzled by the fact that Komplete Kontrol is passing notes without a THRU (which I’m happy with, I have no problem with that at all), and at the same time, Keylab NEEDS a THRU to pass notes., otherwise I have no notes signals. It’s more like an educational query :slight_smile:
testmidiforum.bmtp (3.0 KB)

I’m not seeing anything wrong with the project file. It is working perfectly for me. Do you have any other gear that might be passing these messages through? Are you on Windows or Mac. On Mac, it is possible to have 2 MIDI ports monitored by the same application so maybe your DAW, is listening directly to you KK and also to MT Pro?

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Ah, maybe this is it. On your presets, change your output device from “Bome MIDI Translator 1 Virtual Out” to “Bome Virtual Port 1”. It appears in your router you have things going to the alias but in your presets they are going directly to the port which bypasses. If there are both aliases and virtual ports, you should stick with one or the other but never use both. For ease of maintenance I always stick with aliases.

I’m not convinced this is the issue however, but it is important. Please check my last posting.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

I’m on windows 10, Cubase pro 11. Just checked the Virtual Out 1, no change :frowning:
If it helps. using a Nektar Panorama P6, again needed a THRU to pass notes. It’s the Komplete Kontrol MK2 that seems to not need it. For example, I can set in Cubase the midi input to komplete kontrol and still have midi activity IN, while I don’t from Keylab. I recall that Native Instruments uses BOME. Perhaps, this has something to do with it? :slight_smile:

That is possible. Please set Cubase to only look at BMT 1 and not Komplete Kontrol.


If I set it to BMT 1, I get no notes! I’m really curious why this is happening.

I’m not sure why. Everything is working with my system. Maybe de-install Komplete Kontrol, then re-install Bome MT Pro and see what happens.

Then once you get it working, re-install Komplete Kontrol.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Oh, of course I could do this, but anyway, it’s not really a problem as long as I have no conflicts.
By the way, let me thank you publicly for this magnificent tool! It really transforms our midi controllers to be almost workstations! I literally DON’T touch my keyboard and/or mouse anymore inside my projects. Things like Copy/paste/duplicate, tap tempo (!), zoom in/out and other details that make my workflow fly.
As a ‘thank you’ I will try to upload some stuff I created (cubase specific) demonstrating the great usability of Translator Pro, at least the way I like to run things in my DAW.