BMT not starting on Mac

Hi,

I’ve run into a problem with Bome Midi Translator Pro (1.9.0) not opening on my Macbook Pro. The app icon bounces on the dock a few times but nothing else happens. I’m on Mac OS Catalina 10.15.7. This has been happening almost weekly for quite some time now.

I’m able to restore functionality by first removing BMT from apps, and deleting everything from /user/library/Application support/Bome, rebooting my macbook pro, reinstalling Midi Translator, and restoring application support folder files from an older time machine backup.

I haven’t done any changes to my BMT project when this happens, so this seems weird to me. Also, I’m able to use the latest project file after restoring the application support folder files, so it’s probably not my project file but some of those support files that gets corrupted somehow.

I’ve had no problems with other apps on my mac, only with BMT.
Is this perhaps a known issue, and is there something I can do to prevent this from happening?

Thanks for your help.

…On an unrelated note, I hope the OSC support for BMT and bomebox is coming soon. :wink:

Hi,

I’m not aware of any issues with running Catalina with MPro. I actually run Big Sur which works fine.

You might want to check the options used in MT Pro.

It is possible that you need to launch from the menu bar at the top instead of the menu tray if Options Start Minimized is set in Startup. Also in Options->Appearance. I would check.
Show menu bar icon and Notify when minimized to the menu bar.

Finally check your security setting to ensure Bome MIDI Translator Pro is enabled for accessibility.

Oh and make sure you have 1.9.0 build 1018. If you don’t you can log into your account and download it there.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi again,

Thank you for a quick reply, but this is obviously not a preferences setting issue. Everything is set as it should be.
Again, BMT works just fine until one day it simply won’t start. After removing and reinstalling it works fine for some time until the same thing happens again…

“Oh and make sure you have 1.9.0 build 1018.”

I’m on build 1022, do you mean I should downgrade? I only see one download link on my products page, the latest one.

No, don’t downgrade. I’ll check further but this is the first reported issue that we have had.
Are you running an antivirus program that may be causing the issue? If so, maybe disable it for about a week and see if the problem recurs. If not, enable it and see if it comes back. If your antivirus program has the capability, you could add Bome MIDI Translator as an exception so it is not touched.

As I mentioned, I’ve ben running on Big Sur since it came out and no issues and as you noticed, I’m not even on the latest build but I plan up upgrading my build today.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Nope, no antivirus programs whatsoever. This is a Mac I use mainly for performing and recording.

When I start BMT, only running programs are OSCulator, MidiPipe, Lemur server, touchable pro server and Bome Network. Closing any of those won’t help when the problem occurs.

…and also this problem was present on my mac with some earlier builds as well.

Hi jsulva,
this is a very bad problem. MIDI Translator Pro is built to be reliable and stable in every situation!
Maybe you can help us find out what’s happening?

When this problem occurs again, could you please:

  1. Make sure that a hidden instance isn’t running (Activity Monitor)
  2. Open Terminal
  3. copy/paste this command:

/Applications/Bome\ MIDI\ Translator\ Pro.app/Contents/MacOS/MIDITranslatorPro -debug

It should write some debug info in the Terminal and stop at one point…

Thanks!
Florian

I had this issue as well after a day of use, when loading it would hang on the startup screen, I would have to force quit to close it. I deleted the MTP preferences file (in ~/Library/Preferences/) to get it working again it’s been fine since.

Maybe If @jsulva can provide the pref file, you could diagnose.

I’m only on the Trial, as I’m seeing if I can get my ideas to work.

Note: I’m on Monterey on an Intel MacBook Pro

@slowwild thanks a lot, that’s good to know (or bad, depending on the angle I’m looking at it…). If either one of you can post their preferences file once the problem occurred, that would be fantastic!

In MacOS Finder, use the Go menu, then Go to Folder... and then copy/paste this folder path:

~/Library/Application Support/Bome

In there, locate the file “Bome MIDI Translator Pro.bmts” and post it here.
Then you can delete it (and all backup copies) and try if that fixes the issue.
Thanks!

Will do. I’ll send the debug info and preferences file as soon as this happens again.

Oh, looks like I actually dragged it to my desktop! It’s the plist file in the Preference folder, not the application support directory.

I’ve confirmed that if I drop this back into ~/Library/Preferences, it does indeed hang the app on startup.

com.bome.miditranslator.pro.plist.zip (755 Bytes)

Thank you for the plist file. It’s automatically created and maintained by MacOS. MIDI Translator Pro uses the other file (referenced above) for its preferences.

I’ve checked it out, I cannot see anything unusual. I’ve also copied that over to ~/Library/Preferences and then started MT Pro, but that worked normally. I’ve tested that on Big Sur. Too bad! I’ll test some more on other Macs.

ohh, if you can still reproduce it, could you please run it in debug mode as outlined in Post #7 above?
Thank you very much!

I’ve been trying to get it to crash, and it’s not happening any longer. I will run it in debug mode if it does it again, I’ll be working more my scripts this weekend

Murphy’s law… thanks for all your efforts!

1 Like