BMT Pro - File Open or File Save - No explorer window


I have a problem with my BMT pro.
When I click on File\Open. Nothing happens. There is no Explorer window to choose the file.
It’s the same with the ‘save’ or ‘save as’ options.
I’m on Windows 10 and I tried BMT Pro 1.9.0 and BMT Pro 1.8.4.
I tried uninstall an re-install and runas admin

Any Idea of what can cause this ?

I have another question : My Bomebox is connected to my pc via ethernet.
Does remote midi port works if a BMT Pro is loaded on the bomebox and uses one of the ports enabled as remote midi port ? Does not seems to work here. Once I unload the project from the bomebox. It works.

Thank you,


This type of problem is usually a Windows operating system problem. Do other applications experience the same issue? Check your system settings and maybe change your screen resolution to see if this clears up. Maybe the dialog box is opening on another screen that doesn’t exist.

If it is on MT Pro only, try uninstalling and then remove the settings files. Their location is shown in this post. Then re-install MT Pro.

I would not recommend you run Bome MIDI Translator Pro as admin.

At this time, BomeBox does not use Remote Direct MIDI Ports, so you will need to send MIDI from your computer host to the main network port and then access that from BomeBox. It exposes Remote Direct MIDI ports to computers but cannot access the ports exposed by computers.

If you can provide more details of your configuration, I might be able to advise further of a way to handle this.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi Steve,

Yes, I suppose it is an operating system problem.
I tried your solution but I still have the problem.
Nothing happens, so application is not stuck : In general, when a file explorer dialog is opened, you cannot do anything else than choose a file or cancel. In my case, I can do anything - click a second time on open file or open the file menu,…
I wrote here because it happens only on bome applications.
For BMT, it worked then no more again.
It happens on Bome SendSX 1.4 too.
Bome network doesn’t seem affected (but no file explorer dialog)
Perhaps a dependency (Visual C++ Redistribuable or a java version… don’t know what is used for BMT)

For Remote Midi Port :

  • BomeBox exposes port A
  • Bomebox has a BMT project loaded
  • This BMT project uses port A
  • Does PC can use port A exposed by Bomebox ?

Thank you,


The Windows shortcut procedure for resizing windows.

  1. Open the window (in this case the file dialog box)
  2. Press Alt-Space
  3. Press S
  4. Use the arrow keys to size the window
  5. Press enter when it is the size you want

Yes, on your computer open Bome Network open BomeBox (In My case BomeBoxB)

Then turn on the switch for port A (In my case BomeBox DIN)

Anything coming from port A will also be seen by your computer.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: