Bome MTP 1.9 + Rekordbox

Hi, I’m a brand new Bome user and this can just be the holy grail to solve my issues… I’m this close to purchase a Pro licence and vouch for it everywhere with my fellow DJs / Musicians.

Now… the (small issue)…

I’m currently using an out of date (but very robust and still rocking my setup) a midi controller by DENON DN-HC1000S to control Rekordbox

While it was not working directly, I managed to get most of the needed functions working. I have one single issue which I hope you would help me clarify.

Everytime I choose a function, I’m forced to change channel, or it gets picked up as an already in use signal (button) despite being different. I’m using the the “Capture Midi” feature to pick up the in-signal… to send it out as a message as well… (seems that Denon units only sends half of the value and that’s why Recordbox ignores it" but other than that… I made it work exactly like I wanted…

I’ve attached both configs for you to see.

Eg.

Configs.
DocFUNKist.bmtp (11.2 KB)

Please advise.

R

Hi and welcome to the Bome community!

Could you open the log window and check the “MIDI IN” Box.

Then press

  1. Shift then Files (Holding SHIFT while you press files
    See what MIDI is sent
  2. Shift then Browse
    See what MIDI is sent
  3. Shift then History
    See what MIDI is sent
  4. Shift then Prepaire
    See what MIDI is sent

Copy and paste the log window into a text file or post it here.

Note that according to this document, this should change the MIDI Channel your controller is sending but I’m not sure if it also sends another MIDI message.

I suspect these messages might be interfering in some way.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like

Here is a screenshot of the result in the exact order you’ve asked for it.

OK, so every time you press shift it sends note 96 (Hex 60) on whatever channel it is currently on. It appears that Files, Browse, History and Prepare send notes 100–104 again on whatever MIDI Channel it is currently on. The MIDI Channel it sends changes right after sending these messages.

All of your incoming triggers are looking for only MIDI Channel 2 so if you change the MIDI channel then they will no longer work until you go back to MIDI Channel 2 (Shift - Browse). Instead of looking at note on MIDI CH 2 only, try selecting “any channel” to see if that helps you at all. Of course this means that it will trigger the same outgoing action no matter which MIDI channel your controller is on so maybe you want different outgoing action for each MIDI channel. If that is the case, duplicate all of your translators for MIDI Channel 1, 3 and 4 with different outgoing actions.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi, I don’t believe you’ve understood what I’m after. Based on your response, you’re showing me how to get a different action based on what MIDI Channel I’m on… while what I wanted is… why is different button are being pick up as the same on the output… which means if I press PLAY button…or Cue1 Button… Rekordbox think it’s the same button.

OK, I don’t understand this statement.

How are you forced to change a channel? Show me a log of two different buttons that you push that provides the same output. Check the Incoming, Outgoing, MIDI IN and MIDI Out boxes is the log.

Please annotate the log with each button name that you are pushing. If a button sends more that one MIDI message, then you will only be able to use capture to pick one of the MIDI messages, otherwise you will need to type the message manually in the input as “Raw MIDI”.

Sorry if I’m not understanding you. I suspect your problems are with CC numbers that have different values for up and down since they may be relative encoders.Really hard to tell without looking at one or two specific examples.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi Steve, first thanks for taking the time and you surely don’t have to apologies to me. It’s hard sometimes to describe things when we’re not too technical (speaking about myself) but here I am explaining what I mean by “Forced to change channel” and also try to clarify exactly what’s my issue.

I would like to also make you aware that I’ve not purchased a full PRO license and I really hope this would be worth it.

In regards to being “Forced to change channel”…

As you can see from the 2 first shots… first is for Loading Left button (for DECK 1) and then same for Right Loading button for DECK 2


[Figure 1]


[Figure 1]

Where the arrow is, is where I have to change channel… otherwise Rekordbox will pick the midi signal as THE SAME… (both deck 1 or both deck 2) Check [Figure 3]


[Figure 3]

But by changing channel (wethere it’s the right or the wrong thing to do) IT HAS WORKED.

I managed to get every functions I wanted… the final part to wrap this up… is CUE points… On the unit I have 5 in each side.

I have selected one single input midi signal on each (as there are couple since it’s a PRESS and DEPRESS) I managed to get 6 working but then I runout of channels so it is now picking the remaining press as similar to other on the learning process… Check [Figure 4]


[Figure 4]

I’m baffled because all these are different buttons, I have no clue why are they being interpreted to be the same… it’s like the MIDI OUT SIGNAL IS ALWAYS THE SAME and they are battling which is going to take that function I’m targeting…

I hope this makes sense… if not I can follow up with signal log output… but I thought this should be enough to guide you. If not pardon me and I’ll follow up with more logs.

Here’s a better example to clarify the conflict…

Why in the world… Rekordbox would think that this button and its config bellow…

sync1

Would be equal to the CUE 1 button.

cue1

and will result in…

it is like if all buttons are now 9040 in 9040 out…

Ignore all the above… I figured out the RAW MIDI :wink: It’s all great now :slight_smile:

On a side note and for future users… REKORDBOX is MIDI HACKABLE if you’re on a PAID PLAN ONLY. but Bome has done the trick… the impossible become possible. Nice work!!! Will upload my configs for anyone with the same requirements when I’m done.

R

0K

90 40 is not a complete MIDI message

90 = Note On MIDI CH 1
40 = Note Number
but it is missing the third byte which is velocity

90 40 7F would be a complete MIDI Message

9 = Note On
0 = MIDI CH 1
40 = Note Number in Hex so it would be decimal 64
7F = Velocity in Hex so in decimal would be 127

It is possible that Rekordbox doesn’t look at the MIDI Channel so it might think
90 40 7F
and
91 40 7F

are the same.

Anyway, I’m glad you have it kind of sorted out.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I had it sorted and in the moment of truth… I tested it… I lost half of the configs and when I tested couple to see if I can re-set them, I noticed the RAW VALUE was very different from the one set earlier… is this normal? because of the values change randomly this would be impossible to set.

Please advise.

R

Typically, I use “Capture MIDI” only for simple MIDI messages and then just enter the raw MIDI for more complex messages.

You can use variables for the values that change

For instance. This will send a note on MIDI CH 1 note 1 with value as set it qq within the rules

90 01 qq

For incoming you can use similar and then use the same variable for any output

90 01 7F

edit it to

90 01 qq

outgoing

90 01 qq

Any byte can be a variable. For more information about variables, refer to the user guide by hitting F1 within MT Pro.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I’m honestly even more confused now, if these values are variables, first I need to know which one are, then remediate with your method, I did not think this was going to be this difficult… I should have tested this further before purchasing it, I honestly feel it’s a dead end now, especially not being technical myself.

Hi,

I’m sorry it is very difficult for you. Since Bome MIDI Tranlslator is such a powerful tool, it is sometimes a bit daunting at first until you understand what is going on.

Maybe if you looked at some of our tutorials that would help you more.

We have 40 of them covering some of the basics to some very complex tasks. Most of the tutorials are less than 5 minutes long.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

What device did you enable in Rekordbox? I think it is only supposed to work with certain Pioneer controllers and performance mode is only enabled on those given controllers? What version of Rekordbox are you running? I can’t see anything there that talks about setting up a given MIDI input and using MIDI learn. Maybe you need to upgrade the plan to use MIDI learn.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi, I disabled all but 2 translators here Cue1 and Sync1.
Make sure that RekordBox is only monitoring BMT 1.

It should work without making any changes. I’ve also set the input and output ports for the translator to make sure we only look at data from your controller for input and sent to BMT 1 for output.

This really should not be that complicated so maybe I’m missing something in what you are saying.

Here is what the log shows. For knobs it will be a bit different and if you change your incoming MIDI channel based on my original post it will only work for selecting MIDI Channel 1 for input.

DocFUNKist-sjc.bmtp (10.7 KB)

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz