BomeBox problem or MIDI Monitor problem?

I have a BomeBox with Ethernet cable on a Mac.
There is no Midi Translator file loaded.
In the web interface, I have set two routes bidirectionally between two effect units and the Mac.

On the computer I am working on a Max application.
The current function:
When I change the program directly on a unit, the Program Change comes to Max and triggers a program dump request to that unit. This sends me the current parameter data.

What bothers me is the output of the MIDI monitor:


What is this ‘Network Session 1’?
BomeBox thinks this is an alias of ‘Mac-mini’ or vice versa. I don’t send anything there, from Max I only send to the MIDI port ‘BomeBox - Net’. Despite this, I see program changes and garbled SysEx strings (without EOF) with different lengths, which I supposedly send to ‘Network Session 1’. But I do not. Where can this come from?

Additionally I noticed that the lines in the MIDI monitor multiply after a while of work. First I get everything displayed twice, then more and more, until I finally have to restart the application. Could this have something to do with what I described above?

Maybe there is an unwanted echo somewhere that is causing the problems. The MIDI monitor can’t invent that I send something to a port that I don’t even know …

I have attached the Bome Network.log here. In it you can see that I restart the BomeBox and then quit and restart Bome Network. Maybe you can see something else that I don’t understand and that is not normal.

Bome (1.5 KB)


I would check to see that your Eventide does not have MIDI thru set as this might be creating a MIDI loop.

  1. You trigger a PC with your pedal
  2. Max responds with a SysEX Dump
  3. Eventide Echos ths SysEX Dump back to MAX
    … and so forth.

As far as ‘Network Session 1’ I suspect you also have rtpMIDI on and you are sending to that session which probably goes to nowhere.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

It is also possible that ‘Network Session 1’ is the port name assigned by your Mac to MAX. I’m not sure because I don’t use MAX.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:


It was rtpMIDI. At least I think that’s what the network thing in Audio MIDI Setup works with. There were indeed a ‘Network Session 1’ and a ‘BomeBox’ defined. Heaven knows who did that, but I have a suspicion …

Entries removed, no one sends there anymore, no multiple echoes visible, runs perfectly.

Thank you!

I just see, that MIDI Monitor starts again showing duplicated lines (same time, source and target). It only seems to do this when I talk to the BomeBox. But I think this is the display of the software. Latest version is from January 2022. I will ask the developer.

It would be interesting to see if he same thing happens if you use MT Pro to monitor the MIDI Traffic. I don’t have much experience with MIDI Monitor to know what might be happening there. Thanks for following up!

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

MT Pro does not show duplicate entries. Nothing I send the data through shows duplicate transmissions and the effect only occurs when I communicate with the BomeBox via Bome Network. With direct USB connections everything is normal. So the problem is with BomeBox/Network, MIDI Monitor and/or the Mac itself.

Kurt Revis, the developer of MIDI Monitor, had similar thoughts and also pointed out the spying mechanism of MIDI Monitor, which works outside the regular MIDI stream directly with the MIDI server of the operating system. The latter would be a relatively harmless failure, because it would only be a matter of displaying the data.

With a few tips from Kurt, I started on my journey and it turned out to be probably a bit of everything. After finally killing the ‘MIDIServer’ process in the Activity Monitor several times, no MIDI worked at all and I had to restart the Mac. Now things look different. I think I cleaned the MIDI server, scared the bome system and reminded MIDI Monitor of its duty to cooperate. The effect is gone and hasn’t come back all day.

Everything is running normally.
Fingers crossed, if it stays that way I’m glad the second of the two problems is solved too.

Thanks for the help!

(For someone who suspects similar problems:
I am on a Mac mini M1 with Ventura 13.2.1)

How did you scare the bome system ? :wink:

I have shown that I can take away the MIDI server at any time. An existential threat.

(I didn’t mention that I also need the MIDI server myself. That remains our personal secret.) :sunglasses: