BomeBox: St00pid Old Fart Tricks - MIDISport 4x4 Ports not recognized?

Wow, okay - so I admit that it's been awhile since I've been fudging with my Box: doing some prep work on the computer, recording, waiting for delivery of an interface.

Recently received my Class Complaint M-Audio MIDISPORT 4x4 (anniversary edition if that matters).

Can't seem to get the BomeBox to recognize it.

Old fart bits: Yes, when you get older if you dont' keep using the info (we're talking days & weeks even), you just lose it. So I may be missing something so terribly obvious I should be embarrassed...except I'm old enough that I'm passed the embarrassed part. :)

I'm running tests before dumping my sequences into a hardware sequencer (Elektron Octatrack), so the goal if/when I get this going is to have the computer out of the mix.


  • MIDISport seems to work properly if connected directly to the computer running a sequence from LIVE.
  • MIDISport seems to work properly if connected to D-Link 7 port USB Hub (powered port) to the computer running a sequence from LIVE.
  • MIDISport when connected directly to Box, no ports recognized (Note: because no power, eh?)
  • MIDISport when connected to D-Link hub (powered) to USB port on Box: no USB ports show up on Box configuration

So what st00pid thing am I overlooking? What should I test next?

I'm hoping that via the Box I'll be able to access all 4 ports independently (have three 16 voice multi-timbral modules to control - Yes, I know the OT only has 8 MIDI tracks just go with me on this one, k?)

Note: Have also tried same configuration excepting a D-Link 4 port powered hub instead of the 7 port.
Same results: nothing recognized.

Interesting Twist:
Going back to an older hardware configuration (Roland UM-One -> D-Link 4 port powered hub -> BomeBox) which worked before I took aforementioned ’break’ from being tits-deep in Box stuff, well…the Box doesn’t recognize the UM-One anymore.

So either I’m totally missing something that I knew before, or this is ’that problem’ I had before (last Aug or so…?) that needed a firmware update (because pre-production model of the Box)…?

Just a random thought because this is just not working as expected based on experiences to date.

Additional: even plugged a UM-One directly into the USB port on the Box.
Everything is showing as Status: Unplugged, except (of course) BomeBox DIN.

Wasn’t this the problem I was having last August with the 0.9.5 firmware update?

Try powering your BomeBox with 3rd from right port or further left on (only one of the 5 left port) your Dlink. I think the last two ports are for charging and don’t put out consistent power. On your 7 port hub

Thanks Steve!
Appreciate the assistance in trying some troubleshooting.
Tried that, and it doesn\’t resolve the issue. Still shows all ports as \’Unplugged\’.
Yeaaah…not a DLink 7 port hub issue.
I can dupe this taking the 7 port hub fully out of the mix:
– With a different USB hub (4 port) (Also a DLink but also the first hub I used to use with the Box when I first started working with it)
– MIDIMan Interface plugged diretly into the BomeBox USB port
– Roland UM-One plugged into either hub (and hub plugged into the BomeBox)
– Roland UM-One plugged directly into the BomeBox
Note: My previous configuration that worked a couple months ago was the 7 port hub with two Roland UM-One\’s plugged in and the OT plugged into the BomeBox DIN.
In all situations, all ports except for BomeBox DIN show as \’Unplugged\’.
I believe this \’feels\’ something similar to what I experienced last August when I first received my BomeBox (resolution required a firmware update), but I\’m probably grasping at straws.
Or overlooking something remarkably simple, so keep the suggestions coming if you have any others!
EDIT to add: not used to troubleshooting on this end of things because after the problem I had back in August, I’ve never had to really get into troubleshooting the ports. Everything worked as expected after that. So chances are pretty strong I’m overlooking something remarkably simple.

Adding a comment because it seems when I edit a comment the system removes any paragraph formatting.

EDITING to add:
The problem I experienced before was the BomeBox not recognizing the DIN ports.


What are you using to power your Bomebox?

Wow. Yeah, I didn’t think of that since the previous configuration, which worked for months, was failing to work.

So I tried multiple ’cell phone chargers’ (up to 2.5A), plugging into my computer USB for power, a multi-port USB charging hub (no data, just a box with USB charging ports), and an external cell phone battery pack (an Anker 20000 mAh with 4.8A output).

Getting totally inconsistent results!

Only in one configuration did I get the BomeBox USB to recognize anything, and that was a single UM-One plugged directly into the BomeBox USB port (no hub), but when I went back to that configuration, it didn’t work.

If I’m going to continue with the ’it must be the power’ troubleshooting path, then I’m going to have to create a spreadsheet for all the possible USB connection & power options I’ve tried – except the question remains: Why is the same configuration not working now when it used to work?

That last question is troubling because what happens if/when I get into a live situation where I’m relying on this device and some variable that I’m unaware of has decided to brick to my rig? Ack!

Hi CreepyPants,
sorry to read of these problems. They’re not normal. But it’s significant information that you actually have a pre-production model. In theory, it’s identical, but we did change minor parts of the circuit.

Anyway, it does seem like a hardware issue of some sort. But if you can get the USB port to recognize an attached device at all, then maybe it is a power issue after all. Have you tried using a powered hub? I.e. USB-cable from BomeBox to powered hub, and plug the MIDISport into one of the hub’s ports. If that does not work, there is more than a power issue and you should definitely ask for a replacement unit.


Hey Florian –
Thanks for your response.

I’ve tried two powered hubs – the one I was using when I first received the Box (4 port D-Link powered) and a second one that I purchased several months ago (D-Link 7 port – the same one your sell).

Both have worked in the past connecting the Box to multiple Roland UM-One’s connected to my DIN MIDI gear.

I took some time off using the Box in my home rig. I recently tried to upgrade my MIDI Interface: the Box didn’t recognize a new interface (MIDIMan 4×4), so I went back to my old configuration which worked a few months ago (Box => DLink 7 Port hub => 2xRoland UM-Ones). The Box now doesn’t recognize either of the two hubs that I previously used. (Or rather, nothing plugged into the hubs is recognized by the Box)

The Box recognizes a single Roland UM-One plugged directly into the USB port on the Box. (ie – no hub)

Should I try more power options and/or perhaps a PoE injector? (Even though I’m using the same power supply that has worked continuously for at least 5-6 months before I took a break?)

Thanks for your time.