bomebox upload > Required license name is missing

Dear Bome,

First of all thanks for these great products! I might be overlooking something, but i checked the forum / youtube / and the quick start guide and i cant find any info regarding this. Last week i purchased MTpro and today the bomebox arrived, when i try to upload a file (MTpro) to the bomebox and i select the file, i get the error that the lisence name is missing. If i open the file in a text editor it looks like at the bottom it has my signature. Could you maybe tell me where I go wrong, or which webpage/tutorial I overlooked?

(the file is attached)

tnx in advance,





More than likely you tried to upload the project file that you created with the evaluation copy of MT Pro.

You need to install the paid version of MT Pro, then open the project file and then re-save it. Then you should be able to upload it to BomeBox.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist

Hi Steve,

Thank you for you quick response! It was created in the trial version and later saved from the paid version, just now I uninstalled all bome software and reinstall it and created a complete new file to test, but i still get the same error. Are there maybe hidden files somewhere in windows 10 that need to be deleted as well?

Maybe try saving as a different name, then deleting the original file. Are you sure you downloaded and installed the paid version? It will be located in a different place than the trial version under your account on the Bome web site along with the license key.
Go to ”My Account” then ”Products” and download and install from there.

If you want you can try this file which I saved with a licensed version.



with your file its working. On my side i have first removed my license from the software > then uninstalled all bome soft > restarted computer > reinstalled (MIDITranslatorPro1.8.3_Full_892.exe download from: ) entered the lisence > saved new simpel project and uploaded it to the bomebox. But I still get the same error. Would it help to reset the bomebox itself, or are there other files on windows that need to be deleted maybe? I have been working for a few hours in MTpro wihout getting the 20 min trial quit or any other warnings/errors so I think the license works ok on my computer

Hi, sorry to hear of these problems!

On Windows, to completely remove the settings, invoke Windows Explorer, and enter %APPDATA% in the address bar. Then, navigate to the Bome folder. Delete all files in there.


Also, we don’t recommend to “run as admin”, if you are trying this.

If you are running on a Mac, then go to:

~/Library/Application Support/Bome/
where ~ means your user’s home folder. The “Library” folder is hidden in the Finder, so you may need to use the “Go to Folder” menu item, and enter the path above directly (the ~ works there).
Just remove all .bmts files there, then reboot.


Regarding the license: it will never work to change the license name. The license name and license key must both match exactly for the license to work. Also make sure not to change it in the text editor or it may break the key.

While you are trying that, I will alert Florian to see if there is anything else you might need to do.

Sorry again and thanks for your patience!

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist



Hi Steve, no problem! i have patience:) I tried to delete the files via %APPDATA% removed the license and reinstal everything but this didnt work either

Hi, do you know if there was any special characters in your name for generating the license key? As I understand some non-english characters cause problems for creation of the license key and Florian may need to regenerate one manually. In the meantime, you can email and files you would like to use on BomeBox and I’ll be happy to apply my license key to them and send them back to you for loading. Hopefully this will only be painful process for a short period of time. Just send anything you want license key applied directly via may email address.
Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist

Hi, the name in my license is: znzr , so normal characters. Ill first finish the translator script then and test it on the laptop and then send you if the problem is not solved yet. Thanks for the offer to send me the licensed file back! And thanks for your swift response and help!

After you remove the files in %APPDATA% under Bome, reboot, then make sure there are no .BMTS files re-created there, then give another try. Once you open MT Pro, if there are no .BMTS files, it will create one and that is OK as long as you re on the licensed version of MT PRO.

unfortunatly still the same, also with deinstall / reinstall.

OK, guess we have to wait for Florian to intervene. He is traveling this week but believe is checking his email.

ok, else no problem either, if i finish my MT project before ill send you the file or else ill wait. tnx again!

I have something else you might try if you are running on Windows

  1. Make sure you can find the registration key on the product page of the Bome site
  2. De-install Bome MIDI Translator Pr
  3. Run Regedit and find the registrations keys below and delete them (you might want to make a copy of your registration file first)

HKEY_CURRENT_USERSoftwareBomersBome’s Midi TranslatorRegistration

Then re-install the software and copy and paste the registration key from the Bome Product page when prompted.

I found this old article here that explains my thinking, however it is possible the registration key location has changed slightly so you may have to poke around.

I\'m speculating that perhaps when you installed the software you might have missed a character or two when copying and pasting the registration key. Just an educated guess.


See the snapshot for where I found my registration key. I chopped the key short for obvious reasons.

I also found the .lic file in the path shown in the second screenshot. I think MT Pro also looks here (for instance if you install MT Pro on a thumb drive)

As I said earlier, I would de-install MT Pro, delete the registration entries and the .lic file then re-install MT Pro and be sure to copy and paste the entire registration key.





Hi Steve,

tnx again for all the effort, the regedit/deleting didnt do much, but when i see your screenshot i notice i dont have any .lic file in the same folder (hidden items are visible) maybe there something goes wrong? to open MT i only get the license request 1x so i presume everything there goes ok, also with the regedit, my user/license show up as they should like in your example. See the attached file with the contents of my roaming/bome folder


OK, I guess we will need to wait for Florian to chime in.

Hi, sorry for that! It’s the first time we encounter something like this. I’ve checked your .bmtp file and it seems properly signed. Please contact me at and ask for a new license key, maybe your old one doesn’t work well with the BomeBox somehow.
Best regards,

Hi znzr, any update on this? Thanks!