Bug? Bome Network app loses Virtual MIDI Ports

Hey there,

I have connected a USB hub (connected with some MIDI controllers) to an USB hub (which is connected to the Bome Box USB Host port. When I switch the USB port of the USB hub (that one with the MIDI controllers connected) to a neighbor USB port: all Virtual MIDI ports of the MIDI controllers of this hub are gone. And you can’t the dead Virtual MIDI Ports ghosts. I would assume it’s a bug. A manual workaround is: close the Bome Network iPad app and open the app again. Please see my recorded video for details: BomeBox / Bome Network: bug (?) when I switch the USB port of a hub - YouTube
Sorry for my bad english.

Hi,

Thanks for your report! I will test a similar configuration using Bome Network on my iPad as well as on my computer to see if I can isolate it further as an issue with Bome Network on iOS, Bome Network on Computer, or if it has a problem on both, then BomeBox itself.

Stay tuned,

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hi, I just tested this with my iPad and it works. Maybe on your iPad go to the Setting page of Bome Network and ensure the switch is on for the line saying “Notify Available Network Devices”. See below:

Let me know if that helps.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hey @SteveC,
These are the settings where the error occurred:

Btw: I just noticed more details about this USB bug:

Hi,
Maybe this has to do with the fact you are cascading hubs? Did you see if the same problem occurs if you do not cascade the hubs?

Also when you lose the ports on your iPad (Bome Network), what does the BomeBox MIDI ports web page show.? Does your BomeBox see them or are they also missing from there?
This may tell us whether the issue is within the BomeBox recognizing the ports or Bome Network.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hey Steve,

I recorded some more videos to show what happens here on my side when using just one USB hub but using the same or the neighbor USB ports. See here:

I really hope the dev would implement something so that USB hubs / ports no longer will make trouble – no matter how much USB hubs, what USB hubs and what USB ports I’m using / switching.

Many thanks

Btw: it’s indeed “only” a problem about the Virtual MIDI Ports. Looking forward to get a fix for this. Ideally with one the next firmware updates.

“BomeBox – Net” will get all MIDI messages from all my MIDI gear no matter how much USB hubs I use, how long the USB hub cascade is or what USB ports I use and change.

OK, now to determine whether it is Bome Network or the BomeBox itself.

If you use cascaded hubs on BomeBox, what ports are shown as you move things around there? Is it the same as you see on Bome Network or do all ports show up and disappear normally as you move things around?

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Hey Steve,

I assume I don’t understand your instructions. Should I check the “MIDI Ports” in the browser or should I hit “BomeBox” within the app to show all devices? Could you clarify a bit?

I tried with a cascade of 4x USB hubs. All MIDI devices still will be shown, no matter what USB port / hub / cascade order I use:

Hi,

  1. Plug in all of your MIDI devices and hubs into BomeBox
  2. Show all connected devices (BomeBox Web Ports page)
  3. Unplug one or more device
  4. Show all connected devices on BomeBox again (do they show up again or are they still missing)

In other words, I’m trying to find out if the BomeBox itself sees all ports. If it does and they are not showing up on Bome Network (iPad), then the issue is with Bome Network. If they also do not show up on BomeBox (devices do not re-appear in BomeBox port page), then there is a discovery issue with the BomeBox itself.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

The web page shows all ports again once I connect everything again. No matter what USB ports / hubs / cascades of hubs I connect. And using AUM on iPad is confirming this: MIDI messages will be recognized again within seconds once a / all devices are connected again. See the video for details:

Hi,

We have yet to reproduce the issue. To prevent merged traffic from the BomeBox-Net port, you should turn off Automatic Routes in the BomeBox MIDI Router.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Sorry for the long delay. We’ve been able to reproduce the issue now!
Also Bome Network 1.4.2 on macOS is affected.
The good news is that this bug is already fixed in the current beta version of Bome Network.
We hope to release it soon. Would you like to test a pre-release version?