Cannot see my Audio Interface in the Right Sidebar

Hi. I can see neither my Scarlett 6i6 audio interface, nor my Midiman MIDI interface in the right sidebar.
When I asked about this in an email, I was told to get the name of the Midi Port that is exposed from the manufacturer. So, I have contacted them, and am waiting for a time to chat with their customer support teams. If they tell me, for instance, that the Name of the Focusrite Scarlett MIDI Port is ‘Scarlett123ABC’, what would be my next step? IE, how do I create a reference to that port in the right sidebar of the BMT?
If I were to purchase a new MIDI Interface, say a Roland UM-1, would a new Roland UM-1 automatically appear in the right sidebar? Or would I have to go thru the same steps of contacting customer support at Roland? I am not looking for the cheapest solution here, but rather the most expedient. Thanks!

From looking at the manuals, I don’t think your Midiman or Scarlett is class compliant so that looks like the issue. Do you see any MIDI devices at all?
Could you post a snapshot?

Usually you do not need to ask the manufacturer the device name. It is usually pretty apparent and if not, you can open all available ports and send data from your device until you see MIDI activity coming in using the Bome MIDI Translator Pro Log window.

You would just click the box to open the available port for that device. Alternatively you could set up an alias with your own name and link it to the physical port name that the device exposes.

It would likely show up as “Roland UM-1” or something like that. As I said, it is usually pretty obvious.

Here is a snapshot of a few of my devices.


The one called “Linnstrument” is an alias I created which is linked to on of my Bome MIDI Translator Virtual ports.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi, Steve. thanks for the thoughtful reply.
Yes, my Mac ‘sees’ the Focusrite interface. When I open the Mac Midi Device app, there it is…

I think there is some truth to what you say in regards to being compliant with modern standards… It seems like electronic devices last 3-5 years and then they just quit. If it’s not because of their own failure, then it’s because the rest of the tech world passes them by and they don’t fit in any more.

The weird thing is - and I am just including this for the benefit of the forum - the Ableton Set actually DID work with the MidiPipe Translator software, along with the Tech 21 Midi Moose footswitches, and the Focusrite Scarlett6i6. All 5 foot switches did exactly what we wanted.

Why it only worked for 24 hours and then quit after a soft reboot, we will probably never know.
I assumed it was the free Midipipe Translator software, but who knows. One clue is that Midipipe needed an Applescript to work. And, as I say, it did work - but only briefly. Which of course is not good enough for use in a live performance. To be clear and fair, at this point, the Bome Translator has not worked at all with my Scarlett 6i6 nor my Midiman 1X1 interface. BMT just does not see them.

Maybe someone else will take these facts/ideas and figure out what the secret is, but I am out of time and have to move on.
I have ordered a new ART 1X1 MIDI interface, and I hope that it will be recognized by the BMT, and will function like the plug-n-play kind of thing we have all become accustomed to.

As a last resort, I have dug out of storage my ancient Korg Midi Pedal Keyboard which only outputs Note On Off messages. That would eliminate the need for Midi translator software. The unit is too big for the space, is too heavy and, as I said, ancient. But it never once failed me.

I will check back in here to give a report as to the performance of the BMT with the new interface.

Did you try removing Midipipe? Perhaps it is hijacking your MIDI ports. I had a similar issue with a Windows piece of software called CopperLAN.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

This shows that the Mac Midi app sees the Scarlett 6i6, and Ableton sees it. Today, for the first time, when I opened BMT, the log shows activity. I did nothing different, just clicked the Bome icon to open the app. Now Scarlett 6i6 is showing in the Output section. But what I need is to see it in the Input section. I want Bome to receive a signal from Scarlett. Anyway, you asked for a screenshot so this is it. I just received a new Midi interface. Will try it out after supper, and report back.

Thanks for posting! I’m not sure either the App or Mac sees it as it seems that it is greyed out. Maybe it remembers it before which is why it still shows up. Looking forward to how your new interface shows. Also, you might want to check if your USB cable is good. Did you try using another one? Maybe that is why it was not there and then mysteriously appeared. Maybe just a flakey USB cable.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

This is a screenshot of my MacBook Pro, after plugging in a new ART Midii Interface, and restarting the Mac. My Ableton Project is now, ,once again , working with the SubtleSoft Midipipe Translator. Odd Thing 1: I had to select (in MidiPipe) "2) [Hijacked: USB MIDI Interface]) as my MIDI Input
Odd Thing 2: BMT now displays an Err Msg: "MIDI INPUT ‘USB MIDI INTERFACE’ unplugged. It is set to ‘pending’.
?Q1: If I uninstall MidiPipe, and restart the Mac, will this error in BMT disappear?
?Q2: Am I better off creating an AppleScript like the one you see in the Top Middle of the Screenshot? Or will I be able to simply use the triggers I created in the Preset of BMT?

Sorry, I really know nothing about how MIDIpipe works. Before you de-install it make sure you have a copy so that you can re-install it later if you want. My sense by the term “hijacked” means it is taking control over any attached MIDI ports.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

I closed the Midipipe app and in the Error section of BMT, I see this message: “MIDI INPUT 'USB MIDI Interface ’ now successfully opened.”

Well that is good news!