Can't detect Native Instruments Kontrol F1

Hi Bome team,

I have been loving your MIDI Translator Pro for some time with an NI Maschine MK1.

I picked up a NI Kontrol F1 recently and can’t seem to get it to detect. The F1 has a “Midi Mode” (accessed by pressing shift + browse, similar to the Maschine), but even when I am operating in MIDI mode I don’t see the device under MIDI Input. I have tried a few different cables/ports and have tried re-scanning and closing/re-opening the application but can’t seem to get it working.

Any thoughts on why this device might not show up?

Hi Bome team,

Apologies - you can safely disregard this question. I tried replicating the setup on a different machine and the Kontrol F1 is recognized in Bome MIDI Translator Pro without issue. Something must be up with the first machine I tried this on, I suspect there are some drivers installed by NI Traktor that this F1 unit depends on (Traktor is installed on the 2nd machine, not the first that was having problems detecting it in Bome).


EDIT // just installed the F1 driver from Native Instruments’ website and it’s now detected in Bome on the first computer. I thought the generic pnp windows drivers would suffice - lesson learned! =)


First of all, are you connecting via Windows or Mac? Does the F1 mode specify whether to use USB or MIDI DIN. Of course if it is sending to MIDI DIN, you will need a DIN to USB adapter of sorts on your computer.

If on Windows and using USB , please go to device manager and see if it reports anything. If it does, please check properties, driver, driver detail and see if it is using the generic Windows MIDI driver or a driver by the manufacturer. Here is a screen shot of one of my controllers that uses the generic Microsoft driver which I recommend if at all possible. If using NI driver, you might want to check with them.


Let me know what you find out and perhaps I can assist further.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks, Steve! Per some advice i’ve read in other troubleshooting topics, I thought the generic Microsoft driver would work fine, but I had to install the NI drive to get the Traktor F1 to detect in MIDI Translator Pro. All is working now - thanks for the help!