Can't make Midi Translator Pro work

I would love to make it work, but for some unexpected reasons I can’t:
(First of all, I’m on Mac, 10.13.6, and I’m using Midi Translator Pro Trial 1.8.2 build 853 for now. I will purchase it of course, if I can see it working on my Mac.)

This is what I do:
I want for this example ‘CMD+Backspace’ to delete files when playing a MIDI note on a MIDI Keyboard (Korg NanoKey2)

-I press P+ (New Preset)
-I name the preset (for the example: “Delete”)
-I press the MIDI Port symbol, and I see ‘Project Default MIDI Ports’ opening
-I see my MIDI keyboard in the list, I activate it as Input. Port status indicates ‘open’
-I don’t activate any MIDI output, as I’m looking for remoting a Key Stroke
-I press T+ (Add Translator)
-I name the translator as well (I name it ‘DELETE’)
-I press to the translator and go to ‘Incoming’.
-I see ‘MIDI Message’ and ‘Note On’, I keep these options without modifying them
-I activate ‘Capture MIDI’, and press the central ‘C’ key on my MIDI keyboard
-I see activities in the ‘Incoming’ window (below ‘Note ON’).

This is what I see:
MIDI 90 48 7F
Note On on ch.1 with note:72 (0x48) and velocity:127 (0x7F)
Note On on ch.1 with note:72 (0x48) set ‘pp’ to velocity
MIDI 80 48 40
Note Off on ch.1 with note:72 (0x48) and velocity:64 (0x40)
Note Off on ch.1 with note:72 (0x48) set ‘pp’ to velocity

-I go to ‘Ougoing’
-I select ‘Key Stroke’
-Key Stroke action: I select ‘Physical Keys’
-I press on the line below to select it
-I press COMMAND+BACKSPACE on my Mac Qwerty Keyboard.
-I see: ‘Right Command’, and I press ‘Backspace’ below.
I can see: ‘RightCommand Backspace’
(I notice the Preset and the Translator are still appearing selected, in yellow.
*Just adding this info: I have tried the same process with a MIDI keyboard sending MIDI notes, and with another MIDi keyboard sending CC Numbers, and had the same result)

Now, I select a file to delete in my hard drive
I press the MIDI Key on the same MIDI Keyboard.

And nothing happens. The file is not getting deleted.
Though, I see the same MIDI message appearing in the activity monitor in Midi Translator/ ‘Incoming’ window, each time I press the key on my MIDI keyboard, unless I unactivate ‘Capture MIDI’.

I’ve tried the same process with other Key Strokes, such as Command (w), Command (s), etc, and had the same result.

In the ‘Event Monitor’, when I press the MIDI Note, I can see ‘MIDI In’ reacting, and nothing else.
Do I do anything wrong, or am I missing a step?
Looks like the app is receiving the MIDI data, understands how to transform it into the Key Stroke, but doesn’t play the Key Stroke when I press the MIDI key.

Any idea, any troubleshooting help would be more than appreciated!

All the best from Paris

Hi, and welcome to the forum!

You need to click on the second message. This will bring the incoming captured message over to your incoming trigger. The options there are different ways to capture or interpret the incoming message. Without clicking on it, the incoming trigger will not be populated.

When populating the outgoing keystroke, make sure your cursor is in the box that will be populated. When it is populated, move your cursor outside of that box with a mouse so that it is still not trying to interpret keystrokes.

The other thing to note, is that by default, if Bome MIDI Translator is the application in focus, outgoing keystrokes will be suppressed so you need to have something other than Bome MIDI translator focused to send outgoing keystrokes. You can change this but it is this way by default so that you don’t mess up your programming by sending MT Pro keystrokes while you are programming it.

If MT Pro is not focused, then the outgoing keystrokes will go to the currently focused application on your Mac.

I’m attaching a project file that should do what you are looking for.

midi-to-keystroke-mac.bmtp (878 Bytes)

There are a bunch of tutorials, you can review as well.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:
1 Like

Thank you soooo much Steve!

1 Like