CC control of BPM in FL Studio (Previously Fader Catches value)

I’m trying to make a fine tempo and coarse tempo on the same parameter, with two different faders. But when touching them, each one is jumping the tempo from the current tempo to the value each respective fader is at.

Is there a way for moving the fader to not change the value on screen until it reaches that value? And then it catches it and can move the tempo around from there?

If my fine tempo moves it and stops it at 80, but the coarse tempo fader is at 100. I can move the coarse tempo down, and it won’t affect the tempo box until it reaches 80, so it’s smooth.


Oh, and also I saw the tutorial for changing the 0 - 127 value to the desired range. Is it possible for a huge range, like 10 - 520?

Hi,

Yes this is possible, however I’m going to need to understand how you intend each fader to work with the DAW? Are you looking to change the value of the course fader more for each move than 1 and the fine fader just 1? What is the input range expected from the DAW? Is it 0-127? I assume the outgoing value you want to move 0-127 (7 bit) or is your DAW expecting a 14 bit value?

In general, the trick is to track the current calculated value from both faders and to suppress the output of the translators until the two combined faders value crosses the last known value. Usually the last known value is that of the DAW itself and not the faders.

There are some examples out in the forum but I don’'t think there is one that addresses 2 separate faders doing course and fine tune.

Regarding scaling (your second question), see this tutorial.

So I don’t know what the tempo box requires for an input. Image Line has ignored my question about it.
I made the scaling formula I learned from the tutorial and the output from the translator is working properly. I checked the log window and it’s good. I want a range of 60-240, and the log is showing that.
But it’s nowhere near working on the tempo box. It’s not only backwards but wrong. The first half of moving the fader, it does nothing, just sits at the original minimum of 10bpm, and then the number starts to go up from the last half to max, but the max tempo box number is 251.890. With an outgoing 14 bit message, the tempo box just goes between between 10 and 14.031

Scale Formula
Input is any value, pp. Output is qq.

The original tempo can go from 10 to 522, with the thousandth decimal place (522.000)
Think I’m doing something wrong. I’m really bad at this.

I think that I’m going to abandon the fine and coarse tempo idea. I’ll just use the one basic tempo fader. This scaling is hard enough as it is. The hardware fader is a long dj tempo fader, so it’s perfect for the job anyway.

Hi,
You are using FL Studio, Right? Maybe I can try it. You are using a single fader? Does the controller fader put out 0-127? Does you controller have any 14 bit faders. On a 14 bit fader, it actually will send two separated CC’s, one for MSB and one for LSB. You might get the range with a 7 bit CC but not the resolution.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I don’t think it’s a 14 bit. Shows this:
Tempo Fader
For FL Studio, I’m running version 20.8.2 [build 2215] Signature Bundle 64 bit
I do have to use that fader. I couldn’t see myself using anything else with the tempo.
Can’t change the output either. NI said they are hard coded.
I forgot to mention, if I just use this one fader, then I won’t need a “catch current value” formula either. I’m just struggling with the scaling issue.
Don’t forget there are input formulas in the link to controller box. But I was fiddling with them and it crashed FL Studio.

Hi,

I was able to accomplish what I want with a relative encoder that sends 0x41 for positive movement and 0x3F for negative movement.

I set the output to send B0 00 01 for every positive movement and B0 01 01 for every negative movement
Input: B0 00 qq
Rules:
tt==1
if qq> 64 then pp=0
if qq<64 then pp=1

Outgoing
B0 pp qq

Then in FL Studio for BPM I created 2 links. The port I’m using in this example is 102. Yours may be different.

image

image

Now I can turn CC0 in either direction and get as fine or course tuning that I need.
You can either change tt to a higher number in MT Pro or you can change the multiplier in the formula in FL Studio.

Have fun!

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Yours are 7 bit absolute faders. I set up with 7 bit relative encoders and got much finer control. See last posting.

Image Line did get back to me, and they said FLS is only compatible 0-127 7bit messages.
I’m not even sure which formula you just showed me. Scaling? Fine/coarse pitch?
Can’t even put t==1 in the rules, I get a syntax error. Output value of B0 pp qq gives me a ‘neither number nor variable’ error.
The rest of what you said is far beyond me. No idea what I’m supposed to do.
So I’m just going to leave this alone for now until I have time to study this further.

OK, let me know when you want to come back to it. Bottom line is 0-127 is only going to give you a granularity of 128 steps for BPM setting from your controller. If you want more granularity, you will need to go with an endless encoder and then use Bome to change the CC number and use formulas in FL Studio as I have tested that shows they work, Does your controller have any endless encoders that send relative MIDI messages (besides the platters)?

BTW B0 pp qq is what you put in the Bome output message of the translator, not in FL studio.