Conditional Rule Responses

Hi All!

I just have a quick question. It is quite possibly a very simple answer....I just can't figure it out!

I'm trying to use a cc knob's value to alter some drum pad outputs. So for instance. When cc1 ch.1 has a value of 1, the drum pads would output x,y, and z. When that cc has a value of 2, they out would output a,b, and c. I hope that makes sense. Here's a bit of the code that I've been playing with:

Preset 1: CC 24 Ch10 - assign value to "ga"

Translator 1:

if ga!=1 then exit rules, skip Outgoing Action g0=g0+1 if g0>1 then g0=0 if g0!=1 then exit rules, skip Outgoing Action

Translator 2:

if ga!=1 then exit rules, skip Outgoing Action if g0!=0 then exit rules, skip Outgoing Action


The outgoing actions for the above translators is to change to a cc message CC2 Ch1, with the first translator sending a value of 1 and the second translator sending a value of 127.

The issue I'm having is that even when ga!=1, it sends the translated message. Not sure where to go with this. if anyone could point me in some sort of direction, I would be most appreciative!!

Thanks so much!


I’ll give it a try. Make sure swallow is set on your translators. If you don’t your incoming message will be passed to your default routes. Also make sure if you have any default routes in your project, that they are turned off and then give it a try. If that doesn’t work, post your bmtp file and I will have a closer look.

Edit: Also make sure you set ga to a known state at the start of your project. Variables are not initialized to any known value. Never mind you said your input value set ga so that should be fine, however you did not initialize g0.

So your log is showing that cc2 is being output and not cc24?




I don’t quite understand what you are attempting to do. Maybe someone else can clear this up for you, but in the meantime, couldn’t you just hit the drum pads softer or harder to give you different values.
If you’re after something else, maybe you could explain it a bit differently.
If you’re trying to get the drum pads to send only 1 or 127 and nothing in-between, that’s not too hard.