Connect Digitakt To the Bomebox and to Midi Translator

I spent several hours understanding why my digitakt was showing up on my computer in midi translator and not on the bomebox, and then reciprocally ! So if you have the same problem, here's the soluton.

If you want to connect to your computer and Midi translator, on the digitakt you have to tick :

Settings -> System -> Usb config -> Overbridge mode

If you want to connect to the bomebox, on the digitakt you have to tick :

Settings -> System -> Usb config -> Usb-midi only


Hope that helps.

Thanks for posting! It looks like this is unique to your device and the way it connects to USB. The key is that each manufacturer might have some USB configuration settings that may need to be set up in a given way.

Case and point, last week I discovered the Roland FA-08 needs to use the “Generic MIDI Driver” and not the Manufacturers driver. Evidently the manufactures driver has s dual USB interface for both sound and MIDI that is not compatible. I actually ran into something similar with the Roland A300-Pro some years back. Both required the “Generic” MIDI driver.

I also found that loading the Korg drivers over Windows Drivers on my computer confuses the Windows interface (making other USB MIDI devices disappear) , so I just use the Window 10 default drivers.

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist