Controller sends constant MIDI clock (F8)

A controller of mine, Novation Launchkey Mini mk3, is sending a constant stream of "Timing Clock" (MIDI F8) messages, about 1000/ 20sec. It keeps me from even being able to select parameters via "capture MIDI" because they whiz by too fast. When I connect the device to a daw (Ableton Live) directly, Live's "MIDI IN" light does not show any activity (unless I touch a parameter).

Any idea on how this can be resolved? It's a brand new unit, so I doubt that it's malfunctioning.

Ok - just updated MT Pro from 1.8.1 to 1.8.4 and saw that there’s now a new cog wheel next to “Capture MIDI” that allows raw midi and timing messages to be suppressed (default).
This somewhat fixes the problem. However, I can’t use the status LEDs on MT’s Event Monitor, since “MIDI In” is still flooded and constantly lit, and the icon in the center displays an interesting animated flash across the logo.

I can make do with this, but I am wondering:

Does this potentially add to overall midi lag? ..or to other issues like higher CPU load?



additional question:

In the Event Monitor, shouldn\'t this type of incoming message light up the “Timer In” LED instead of the “MIDI In”? I know it’s not the same as MTC, but still wondering if it wouldn’t make more sense to separate it from the “MIDI In” indicator in a future update.

…and now I have found the “Allow Timing Messages” option in the right-click menu of the port alias! (and disabled it)


Should be all set now.
I considered deleting this thread, but figured someone else might find it helpful.

– Max


Hi, as you already discovered you can modify the behavior of capture MIDI with the gear icon.

You can also completely disable incoming timing clock messages by right clicking the input port and then unchecking Allow Timing Messages with a left click. Doing this will also disable the messages from reaching the Event monitor or anything else within MT Pro.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist



No, timer event is for user created timers, not for MIDI messages.

Note that for those who find this thread because they have the same problem with the same Novation Launchkey Mk3 controller: you can turn this off on the controller itself.

Press the “settings” button, then use the down-arrow pad until you get to “MIDI clock out”, press the top-left pad to set it to off, and you’re done. No need to make software filter out the events when you can just turn them off on your hardware =)