Controllers using same midi channels and same CCs/notes

Hiya !

I have this problem where my controllers are clashing each other because they’re using the same midi channel 1…

Is there a way to route them so they just don’t interact with each other? (i mean instead of changing the channel of one of them)

(Btw is it normal that when I plug a controller, the leds from another controller are going off then on again ?)

I don’t get it because they’re not using the same midi port, here is my setup

Have a great one !

The MIDI router in Bome MIDI Translator will route all MIDI signals on all channels between the ports select. If you want to restrict the channels or certain MIDI message from a controller on a given port, then you will need to use translators.

Also, I noticed you are not using aliases. You might want to look at the tutorial on the use of Aliases.

You can learn more about aliases from this tutorial.

If you want to only process MIDI In from a given port using translators and specific transformations. Look at our tutorial on device selection.

For more information about device selection, see this tutorial.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Ok thanks for your help Steve !

Great tutorials!
I’ll modify my file using specific preset routing as much as I can and repost if it still doesn’t work

1 Like

I don’t get it… getting desperate here

Can’t figure out what routing to do, I’ve tried pretty much everything all morning but still can’t make it work…

I simplified it with a new project file and only 2 controllers and Traktor:

Traktor settings:
MFtwister: in port = BMT1 and out port=BMT1
Launchpad: in port= BMT2 and out port=BMT2

Project default midi ports and routing:
MFtwister sends to BMT1
Launchpad sends to BMT2

1- MF twister all CC and notes are translated into variables // Routing by specific midi port:
*input= BMT1
*output is BMT6 and BMT7 and ‘midi fighter twister’ for the LED feedback

2- Launchpad all CC and notes are translated into variables
*input= BMT2
*output is BMT4 and BMT5 and ‘launchpad’ for the LED feedback

It seems to work this way, I don’t know if it’s mean to be ^^ but well :smiling_face_with_tear:

But then I add a line in traktor called ‘send monitor state’ that I use to refesh the leds when changing ‘layers of LEDs’
and then when I press the CC mapped to the ‘send monitor state’ on the launchpad and monitor messages in the log window, I see messages MIDI OUT MIDI FIGHTER TWISTER sending RAW MIDI

I tried to add the ‘send monitor state’ in a separate generic midi device with In port= BMT2 (launchpad) and out port = none
but still get the RAW MIDI from the midi fighter


NEW TEST.bmtp (3.6 KB)

I just looked at the project file and you have output ports set to BMT6 and BMT 7 on preset 1 instead of BMT4 and BMT5. Maybe that has something to do with the issue?
I’m not sure what you are doing with BMT 6 and BMT 7 inputs.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Well it doesnt really matter I just used the BMT 4-5-6-7 to check if the messages were sent correctly through the ports !

BTW I gave up on that…
Its too complicated for me as the main controller is also custom mapped through remote script so I can’t really interfer with that…

To make my life easier I remapped the clashing controllers on different channels, I’ll see how it goes

Maybe one of your MIDI controller destinations has MIDI thru. I don’t know, I didn’t see anything wrong. If you set MIDI IN and MIDI OUT in the log, then you can probably trace the path that is triggering your MFT.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: