Digitakt as Slave


I just purchased Bomebox and Midi translator and trying to figure out how to configure Elektron Digitakt slaved to Squarp Pyramid sequencer. When I send SONG START from Pyramid to Digitakt, Digitakt follows its internal sequence and starts first note most of the times late (for example: 16 steps, notes on 1, 5, 9 and 13 - Digitakt starts sequence usually on 5th note). I need to force Digitakt to start first note instantly when triggered from Pyramid. I tried to configure it in Midi translator like: FA -> FC FA, but with no success. Anybody with similar setup? Any hints appreciated, I'am kinda lost :-)




Hi Lucas,

Do you have your Digitakt configured to receive timing clock from your Pyramid? Start message should usually be followed by timing clock at 24 clocks per second. Also make sure in MT Pro (or BomeBox) that you either have a thru path enabled between the devices or set up a translator to pass these clock messages through.

Finally, I’m really not that familiar with either of the devices but I thinking if the Digitakt is programmed to start and is currently in the middle of a loop, it might be waiting for the next loop iteration before starting.

Another thing to consider is to configure your Digitakt to receive parameters via NRPN instead of CC, just in case the Pyramid is sending CC messages that have different meaning for the Pyramid and the Digitakt. Either that or filter these CC messages from getting through with MT Pro project.


If you can show a log of what Squarp is sending and annotate it where you hear the Digitakt start, maybe I can look into the MIDI stream more precisely to determine what is happening.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist


Hey there. I think you asked this on the Pyramid forum also.


More appropriate for here. 🙂


So, a quick look seems that the DT responds to PgmChg, so yeah:


Incoming: PgmChg, set value to oo

Outgoing: FC Cn oo FA


Where n=Autochannel in hex


Assumption: you are familiar with relating to MIDI in hex, you have the Autochannel set correctly, etc


Note: this starts your patterns from the 1. It does not flip between patterns within a measue

Thanks Jim! I was hoping you might chime in since you also have a Squarp Pyramid.

Yup, and i have that Translator since my Pyramid controls an Octatrack.

One of the OS updates has a ‘fix’ where theres a MIDI msg that lets you avoid this, but i have no need to change because my system aint broke.

Well, yet

firstly, thank you both for your answers.I am playing with that for more than week now, it seems I am step further, but still not working as desired. I was able to get it work when I use Midi translator on my mac and both devices are connected to computer – not to Bomebox (please see screenshots how I programmed it, it’s probably not the best code, but it works). I use midi channel 15 for this connection exclusively. Sequence starts immediately and changing patters are managed by Pyramid sequence as I wanted. HOWEVER, when I load THE SAME project to Bomebox and connect both devices to USB hub plugged to BB, it’s completely broken.I checked multiple times if I have proper midi routing (through aliases I created in Midi translator) – no luck at all, Digitakt lives its own life. I checked also NRPN possibility as you’ve mentioned, but cannot figure it out for now. I will appreciate any further hints, thanks for great support.



Hi, could you tell me what version of BomeBox Firmware you are using? If not 1.4.1, then please download it and upgrade.
A way to troubleshoot it is to Create an Alias for your Digitak, assign the alias to Bome Network Port of your Mac, and then use MT Pro on your Mac with logging turned on to see if anything is coming through on the log file. I know that there were a few intermittant routing problems with BomeBox firmware prior to 1.4.1.
Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist
Another thought is on MT Pro, it looks like Elektron Digitak is defined as Elektron Digitak out 1 and on BomeBox it is defined as Elektron Digitak USB. Please make sure that your project on BomeBox is not really trying to send to Elektron Digitak out1. Maybe it thinks this is an alias.

Another thing to test. If your Digitakt is set for Turbo USB, turn it off or instead of using USB, connect the input of your Digitakt to the output MIDI DIN port instead.