Error message: This project file is not compatible with this version of MIDI Translator

"This project file is not compatible with this version of MIDI Translator.
Please try to get an updated project file."


How do I fix this error? I have not changed any settings or updated/downgraded the software and now suddenly I cannot open my project. I have attached the file to this post. I'm running version 1.8.4 build 962


The file you posted is a completely empty file, or more accurately a 12KB file filled with zeros. Check for any backups that you might have made.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist

Were you able to get this sorted out? Hopefully you had a backup file.


I have also just had this same problem happen to me this morning when I started up my workstation.

Last night when I shut down my computer after an evening in the studio it crashed to the Windows Bluescreen error while windows was shutting down. This is unusual, but I put it down to the fact that I was messing heavily with a lot of MIDI apps last night. During that session I had also reconfigured BMT Virtual Ports and BMT had complained about not being able to close and open ports properly so things were in a little bit of a state. I didn't think much of it, my computer Bluescreens about once a week due to MIDI issues...

This morning, when I launched BMT the splash screen showed (it is usually switched off) and then a dialogue popped up saying that it was going to reconfigure the Virtual Ports, and I clicked OK. Then it showed a dialogue saying that the BMT settings file was corrupt.

I then opened the main BMT window and it was like opening BMT for the first time. There was only 1 Virtual Port, and the selection and routing of MIDI ports was all reset to nothing

Then I tried to load my project and I also got the message “This project file is not compatible with this version of MIDI Translator. Please try to get an updated project file.”

I don't have any backups, but I have only just started using BMT and I only had 2 translators which I could remake quickly. so this is no terrible loss, but it is very concerning.

Why does this happen? Is file corruption with BMT a common problem?




Hi Sam,

I've been using MT Pro for years and have NEVER run into anything like this. It sounds like there may be more serious issues with your computer if it blue screened on you as well. It is always good practice to save your project file shortly after creating it. The only time the project file is actually written is when you save it. When MT Pro opens it, it simply reads the project (.bmtp) file, but it might write to the settings (.bmts) file when adding or changing aliases.

When MT Pro opens again after a save, it always looks for the last project file saved. If it can't find it, it should just open with a new blank project file but I've never seen the error you described unless perhaps you open it in another application and you save it from there after making changes.

Usually if you have troubles opening MIDI ports, it means another application is also trying to access those ports. Other applications could open a port (if your not using it in MTPro) and then later if you try to open it, you could get a pending error (until the other application releases the port).

If the settings get reset, it usually means a corrupt or missing settings (.bmts) file but MT Pro keeps backup copies of these in the %APPDATA%\Roaming\Bome folder. If I remember backup files of the project (.bmtp) files might be found in %APPDATA%\Roaming\Bome\TempProjects but with a generic name such as MIDITranslator_tmp.1.bmtp

You might want to look there if you have lost a working project and have not yet saved it or it has otherwise become corrupt.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist


Hi all, I have two project files that now give this message and will no longer load. (719.2 KB) (436.6 KB)

Neither of these files look like they are Bome MIDI Translator Project files. They have the right file extension, however they look like binary files and .bmtp files are text files.

Maybe see if you saved the original files somewhere else?

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks Steve, I created these yesterday and they worked until this morning, then that was that. Odd hey!

Yes, strange, they were also way to big to be .bmtp files. Even the most complex ones are not that big. Maybe you downloaded something from youtube and overwrote the orginal files?

I assigned them an icon, perhaps the OS tried to embed that. Oh well! Rebuilt them.