Incoming key stroke to outgoing mouse button click in Cubase

Hi Steve,

Using MTP to remap a MIDI hardware controller and very happy with it!

In addition to this, I was hoping to use MTP to convert a few incoming key strokes to mouse clicks at a specific position in the Cubase 9.5 user interface. Looks like Windows Inject Event doesn't work (no mouse handling class for Cubase), so I have set it up manually. The translation works fine when I have the Bome program or any Windows window open. However, as soon as I switch focus to Cubase, the translation doesn't work anymore. I have made sure that there is no Cubase key command assigned to this particular key stroke (I am using Ctrl+Alt+Q). Could Cubase be catching all incoming key strokes in this case and is there a way to make this work?


Well, I\'m using Cubase 10.5 and it works with one caveat. Since MT Pro does not suppress incoming keystrokes, I think that Cubase is seeing the mouse a control(Alt(q)) Plus left mouse click (the original key stroke plus the click).

In my case I was selecting another track so the original track was not deselected.


So my recommendation is that you use MIDI In and then mouse movement/click out instead of keystroke in.


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist




Thanks for your assistance, Steve.

I have used a MIDI button on my hardware controller as incoming trigger, set up exactly as in your example file. But the result is the same.

When I press the MIDI button with Bome open or any Windows application/window open, the mouse click works as expected. However, as soon as the Cubase 9.5 main window has focus (while Bome is running of course), the outgoing action does not happen.

Any other suggestions? Would love to get this working in Cubase.

Hi, maybe you can download trial for 10.5 and see if it works as 10.5 is working on my Windows 10 PC. I have not tested on Mac however but if you are running on a Mac, check you accessibility settings and make sure you enable Cubase for accessibility, otherwise maybe it will not process keystrokes.

Thanks, Steve. I’m on PC, so I will revisit this when I upgrade to Cubase 10.5 or 11.

Do you have function lock turned on ?


Hi, Steve. Just letting you know that the problem turned out to be that I wasn’t running Bome as administrator in Windows 10. I have set Cubase to run elevated (run as administrator) by default, so that was the reason Bome wasn’t able to communicate with Cubase :-).

Thanks for letting me know. Normally MT Pro does not need to run as Administrator. Is there a reason you are running Cubase with extended privileges?

There was a reason for it, but I forget. May be a Windows 10 PRO thing. For MIDI communication via the Bome virtual ports, it didn’t make any difference. It was only when using Bome to send mouse clicks that I ran into this. Anyway, running Bome as administrator solves it. So my mistake, this had nothing to do with Bome.