Incoming/Outgoing Triggers not saving

All I need is to filter MIDI in/MIDI out. 16 chanels in but I only want Program Changes in chanel 15 to come out.
I have Bome’s Midi Translator Classic running on an XP computer. My friend did it successfully on his computer for many years, but he is gone and now I must do it myself on my own computer.
The problem is when I am creating or editing a translator I set the Incoming Trigger or Outgoing Action to MIDI Message but as soon as I leave that window it makes it into “Unknown Action”, even if I hit the “apply” button before I leave the Edit window.
I have tried the same thing on another computer with a later operating system and I get the same result. The Preset and Translator are both set to active…

What am I missing? What could be preventing me from being able to save the settings as MIDI Message?

I’m not sure but if you are trying to write you program in Bome MIDI Translator Pro and then use it in Bome MIDI Translator Classic, it will not work.

The attached project file is written with Bome MIDI Translator classic.

  1. I have set the MIDI thru option so that all MIDI messages are passed through that do not have translators
  2. I have two translators. One converts PC from MIDI CH 1 to 15 and the other from MIDI CH2 to 15. If you want to convert other channels just duplicate and edit the incoming values of each translator.

Of course you need to define the input and output ports you want to use.

PC-to-CH15-Classic.bmtp (289 Bytes)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks Steve.

I didn’t want to change anything, just to stop the other channels from getting through. I ended up adjusting yours so it had only #15 CEpp as the trigger, and #15 CEpp as the outgoing action and that achieved I needed.

I do live performance (accompanied by a MIDI file) on several instruments including a DX7 which has no ability to select to receive only one channel. It receives and tries to play all MIDI messages from all 16 channels, so I needed to stop everything getting to it except the prog changes on #15.

The reality is, when I put up the previous post on this forum I was also trying to get the DX7 to receive notes on #15 for when I was playing another instrument, but part of the issue was I needed to send both note on’s and note off’s. I think I was typing something wrong, and that’s why it wouldn’t save. I was using #15 8Ennvv in both incoming and outgoing to let the note off’s through, and #15 9Ennvv for the note on’s… I got frustrated with not being able to save the translators so I thought I’d just simplify and get one issue solved at a time.

Anyway, the PC is fixed and thank you for your assistance, but could you guide me on what I should put in the translator to allow notes through on #15?



Since you have MIDI Thru set. All notes on all channels will go through. If you only one all notes on MIDI CH 15 to go thru, you need to block notes on all other MIDI channels by adding note translators for the channels you don’t want to go through with an outgoing message of “none”.
So in all you will have translators for all Note On and Off messages with outgoing of none for any all but MIDI CH 15.

The other way you could do it is turn off MIDI thru and then only add translators for the messages you want to pass through.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thanks Steve. I’m on top of it now…

Sounds great!

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

A post was split to a new topic: MT Pro with Windows XT and Cell phone or tablet