Installation problems


I’m having troubles installing the new Bome MIDI Translator Pro 1.9.
If I choose ‘standard’ installation, I get ‘An error occured installing the virtual MIDI port(s).’ and application doesn’t start and I get no error msg on WIN10x64, on WIN7 I get ‘Bome MIDI Translator: MIDI engine and router has stopped working’.

If I choose ‘custom’ instalation and I select ‘force reinstal of virtual ports’ I also get ‘An error occured installing the virtual MIDI port(s).’ on both WIN10x64 and WIN7 and application doesn’t start.

If I choose ‘custom’ installation and I deselect ‘instal of virtual ports’ it installs ok, but it doesn’t start, on WIN10x64 with no error msg and on WIN7 I get ‘Bome MIDI Translator: MIDI engine and router has stopped working’.

If I revert back to MIDITranslatorPro1.8.4_Full_962, it works fine.

On another PC running WIN10x64 and on 2 virtual PCs running WIN7 it works OK.

Bome Network v1.4 installs ok on all systems, I have registerd version.

What could be the problem?

Hi, I’m sorry you are running into problems with the installation of Bome MIDI Translator Pro 1.9!

First, check if there may be other applications running that use the Bome Virtual Ports. If there are, they may be holding a port open which might be problematic in de-insalling and re-installing virtual ports. Make sure any programs that use MIDI ports are not running and try again.

If this doesn’t work, you may need to go into Device Manager and delete the virtual ports and then try re-installing Bome MIDI Translator Pro. There are two places to do this in Device manager.

To start Device Manager you can Press Windows+R and then type “devmgmt.msc” into the dialog box and click OK.

Once open look under "Sound, video, and game controllers. Right click on the device in question and then click “Uninstall Device” . Do this for each of the Bome Devices. In the below example it would be BMT 1, BMT 2 and BMT 3.


Then go to Software Devices and do the same. There are usually 2 software devices for each virtual port. Again, BMT 1, BMT 2 and BMT 3 in this example.


To ensure a clean installation, it may also be prudent to go remove the existing installation of Bome MIDI Translator Pro.

Press Windows+i to get t the Settings, then click on Apps. Find Bome MIDI Translator Pro and click uninstall.

Then restart your system and try installing Bome MIDI Translator Pro again and use the “Standard” option.

Please let me know if this solves the issue.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:


I did what you suggested, but no luck.
I tried it on WIN7 and WIN10x64, I noticed I also get an error when uninstalling BMTpro (error occured when removing virtual ports).

  1. uninstalled BMTpro1.9, BomeNet 1.4 and Bome Virtual MIDI
    this is WIN10x64 after uninstalling:
  2. restarted pc and made shure there are no apps holding BMT virtual ports.
    3 installed 1.9 but I get the same errors
  3. I reverted back to BMTpro 1.8.4_Full_962 (without uninstalling 1.9 or rebooting) and that works fine.
    this is WIN10x64 after I reverted back to BMTpro 1.8.4_Full_962 and installing BomeNetwork 1.4:

I will try uninstalling VB-audio, maybe that will do the trick…but on one WIN7 virtual machine it works fine with VB-audio installed, so I don’t think that is the problem.

Something still looks wrong. You should not have 4 BMT 1 Software devices, so it looks like that might be the crux of the problem.

Try shutting down Voicemeeter when you do the installation. I’m thinking maybe you are using their MIDI implementation in your settings and it might be holding BMT 1 open. It is pretty easy to just run it again when you are done.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:


i did shut down VB-audio before installation and it didn’t help, I’ll try uninstalling it on one machine to see how that works…but it’s interesting that I din’t have any problems with previous installations…


uninstalling VB-audio did not help either.

Are you using any other MIDI virtual port software like LoopBe or LoopMIDI? Maybe there is a name collision with other software you are running. Like in LoopMIDI naming a port “BMT 1”?

I’m also checking with our developer because I think he had some sort of magic virtual port driver de-installation tool. I had a similar problem pop up 3-4 years back on one of my machines. It this case it turned out I was using CopperLan which was interfering with my MIDI ports.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi @primozz , sorry to read of these difficulties. Please close all applications that might be using MIDI, then reinstall MT Pro. Please use Custom mode, then check “Force reinstalling the virtual MIDI driver”. That should take care of any virtual MIDI issues.
Let us know if that worked.

I’m using rtpMIDI (for my iconnectivity mio10), I checked names and they are not identical with BMT.
Also it’s working fine on another WIN10x64 machine and 2xWIN7(virtual), with rtpMIDI and BMT 1.9 installed, WIN7 also has VB-Audio Virtual Cable installed(but not running Voicemeter).

I did try “Force reinstalling the virtual MIDI driver” too, but no luck.
I also tried installing BMT1.9 with no virtual port support and that did not help.

Hi, could you please check if there are crash reports? Even one from Windows 7 would help a lot.
Crash or Freeze? Please send us a dump file!


I’ve attached crash reports from all 4 machines, 1xWIN10x64, 2xWIN7 and 1xWIN7(virtual on ESXi). (745.8 KB) (283.9 KB) (426.9 KB) (567.2 KB)

Hi @primozz thank you very much! Unfortunately, the crash is occurring in the bootstrap code, where we cannot do much. Maybe this is just because of lacking virtual MIDI support?

Anyway, could you please try with this debug script: (317 Bytes)
And see where it stops?

Hi Florian,
should I install BMT1.9 first and ther run the debug?
I installed 1.9 standard on WIN10x64 and after running .bat I get:

Attached to console.ResourceManager resource configuration:

  • Current directory: C:\Program Files (x86)\Bome MIDI Translator Pro\
  • Property count: 18
  • Property: arguments=<>
  • Property: bundledvm=
  • Property: classpath=<MIDITranslator.jar>
  • Property: currentdir=<${EXECUTABLEPATH}>
  • Property: embedjar=
  • Property: javapropertiescount=<1>
  • Property: javaproperty_name_0=<bome.exe>
  • Property: javaproperty_value_0=<${EXECUTABLEPATH}${EXECUTABLENAME}>
  • Property: jvmsearch=
  • Property: mainclassname=<>
  • Property: maxversion=<>
  • Property: minversion=<1.7.0>
  • Property: skel_Debug=<0>
  • Property: skel_JniSmooth=<0>
  • Property: skel_Message=<Corrupt Installation. Please reinstall this software,
    or contact Bome Software at>
  • Property: skel_SingleInstance=<0>
  • Property: skel_SingleProcess=<1>
  • Property: skel_URL=
  • Arguments count: 2
    Main class:
    Currentdir: C:\Program Files (x86)\Bome MIDI Translator Pro
    Now searching the JVM installed on the system…
    Found a vm bundled with the application: (jre)
    Current directory is C:\Program Files (x86)\Bome MIDI Translator Pro
    JavaMachineManager: setting 0 JNI libs
    Running now <C:\Program Files (x86)\Bome MIDI Translator Pro\jre><><0.0.0>, just instanciate=no
    Launching <C:\Program Files (x86)\Bome MIDI Translator Pro\jre><><0.0.0>
    RuntimeLibPath used: C:\Program Files (x86)\Bome MIDI Translator Pro\jre\bin\client\jvm.dll
    No version, trying with 1.7.0
    SunJVMDLL: Got 0 JNI libs
    ClassPath element is C:\Program Files (x86)\Bome MIDI Translator Pro\ + MIDITranslator.jar
    ClassPath element 0=C:\Program Files (x86)\Bome MIDI Translator Pro\MIDITranslator.jar
    VM Created successfully
    DLL Setup on 1.7.0
    Classpath: -Djava.class.path=C:\Program Files (x86)\Bome MIDI Translator Pro\MIDITranslator.jar;
    Option added:-Dbome.exe=C:\Program Files (x86)\Bome MIDI Translator Pro\MIDITranslator.exe
    VM 1.2+ Created successfully !!
    Result code on DLL: TRUE
    Looking up for class <com/bome/mt/swing/MidiTranslator>
    Can’t find class com/bome/mt/swing/MidiTranslator !
    Looking up for class <java/lang/String>
    Looking up for class <com/bome/mt/swing/MidiTranslator>
    Can’t find class com/bome/mt/swing/MidiTranslator !
    Press any key to continue . . .