Issue with USB MIDI on Minilogue xd firmware 2.10

Hello Bome Engineers! Loving the smoothness of the latest Bome firmware and would like to thank you for all you do.

However, I have encountered an issue in my setup as it pertains to USB MIDI being sent from the Bomebox to my pair of Minilogue xd’s after updating to Korg’s most recent firmware (2.10). I noticed it after updating the first of the synths. It actually worked for a little while, so it was a surprise when it all of a sudden stopped working. I had a suspicion it was the firmware so I decided to wait a few days before updating the firmware of the second synth so I could run a slew of tests to determine the cause.

Aside from USB MIDI from the Bomebox, the synth is fully functional with receiving MIDI notes. The DIN input works fine. The USB port works for sending MIDI notes directly from a simple keyboard app on my computer, as well as connecting and transferring information to the companion librarian software. I ran different variables and versions of these tests and they all seem to point to the Minilogue’s firmware since, all the while, the second (control) Minilogue continued to work flawlessly with the Bome Box.

After running all the tests, I updated the second Minilogue. Experienced the same results to an exact degree. It worked for a while, continuing to behave as it always had. Then all of a sudden…totally unresponsive. Kind of a bummer, but I understand the compatibility between all these firmwares and devices is super complicated and issues like this arise. I’ll survive on the DIN ports, but I wanted to bring it to your attention so hopefully one day in the future I can return to using the USB ports for my particular setup.

EDIT: Forgot to specify that even though the Minilogue running firmware 2.10 wasn’t receiving notes over USB, the Bomebox still recognized it on the list of MIDI ports in the Web Config (and would subsequently recognize whenever I unplugged the USB cable). Just wanted to include that factor.


Thanks for letting us know. You might want to talk to Korg about their compatibility. Perhaps they broke USB compliance with their firmware update. Perhaps there is a “compatibility” mode in the new firmware. Check their release notes or updated manual.
Some vendors do this where they have a “class compliant” driver and an “extended feature” driver that only works with their supplied USB drivers which of course they only provide on Windows or Mac.

For instance, I have a Roland device that has an enhanced mode which only works with their driver on Windows so don’t install the special driver and in the firmware mode, I leave it on the normal “compatibility mode”

I’ll check with Florian also to see if he can reach out to Korg for help to see what they did.

@FlorianBomers FYI.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thank you Steve (and Florian). I’ll try with Korg and see if I can get anything.

The best way to test it is to de-install the Korg MIDI drivers on PC or Mac. If it works there with the standard OS drivers, it should work with BomeBox too.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: