Keystroke not recognized

Hello! I'd like to use my Midi Interface for some Commands in the Microsoft Flight Simulator 2020.

This Script works in the Windown 10 Editor but was't recognized in the key mapping in the simulator.

Please help me out!

Thanks Alex


Hi Alex,

On the Youtube comment, you said you had resolved this? Could you tell me what you did or do you still need help?

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

No Steve, this Problem wasn’t solved.

No Steve, this Problem wasn't solved!

Hi, I don't have Flight Simulator but as you say, it looks like it works in a text editor. Do you have FS as the current active application when using the project file?  MT Pro by default will send to the currently active application only.  On Windows, you can maybe try using injected keystrokes which will target the application and control you have selected when you set it up instead of the current application. If that doesn't work, perhaps FS is bypassing the Windows keyboard drivers.  Are you running FS on Steam or native Windows 10 version?

Does FS have a demo version? If so, maybe I can load it and test it more for you.


Also, maybe make sure you keyboard doesn't have numlock on. 

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:


Thanks for your care, Steve! No, there is no Demo Version of the MS FS 2020. What do you mean with "active"? Assigment (mapping) happend within the App. In this case it's for the assigning the rudder (left and right) and the breaking.

Please take a look at youtube, timecode 3:23, there you can see how it's done.

The Sim runs under Steam and under Windowa, in my case it is native Windows 10. Numlock was off.

Sorry, I didn't understand what "injected keystroke" means and how to realize it.

Thanks again, hopefully


Hi, see if you can set it up for different keystrokes to see if it works. For injected keystrokes, you check the button injected keystrokes, then find and select a control you want to send the keystrokes. You can read the manual if you need more information on how to do this by pressing help or F1 in Bome MIDI Translator Pro. Injected keystrokes, however are kind of a hit and miss depending on the application.

By active, I mean the FL2000 needs to the the window on top and in focus.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Steve, similar to OP, I was hoping to use BMT to control autopilot knobs in Microsoft Flight Sim 2020 but it just doesn't seem to recognize any of the BMT simulated keystrokes in the game. Keystrokes work fine in text editor and even in MSFS 2020 menu, but once loaded in the actual game, none of them work. I tried running BMT as admin and injecting into MSFS - no luck. I would really appreciate any help on this, thanks!

Here\'s an interesting find that might help: in Microsoft Flight Sim there are two ways to search key bindings in the control settings (two text boxes in my screenshot).

1) by typing in the name of the command (e.g. \"Engage Autopilot\", \"Decrease Throttle\" etc.)

2) by pressing a key or a key combination. If such command exists, it will show it in the list.

So, BMT keystrokes WORK in the first field where text is expected, but they DON\'T work in the second field where the actual key commands are expected. So I think this is related to the fact that BMT keystrokes are not recognized in-game



Thanks for reporting the alternate solution! It appears that FS must have a "hook" into the Windows driver for single keys but then still allows "text" commands for functions. It is always handy if the developer of an application thinks ahead and has multiple ways of getting to the same function. This may not have been part of the design but just our good luck. I'm sure other Flight Simulator users will appreciate your follow-up with the solution you found!


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:


To be clear, I haven’t provided a solution haha! BMT still doesn’t work with the Flight Sim, I was just chiming in to provide some extra information on this issue. I would really appreciate any help with this.

Thank you.

So if you send it a text string from MT Pro it also does not work? I’m afraid I won’t be able to do any testing of FS unless I buy it and then there is no guarantee it will work so I rely on current FS users to let me know if the solutions I suggest work correctly?

Steve Caldwell
Bome Customer Care
Also available for paid consulting services:

Thanks Steve. I'm willing to try every solution you come up with and report back.
No, sending a text string doesn't register within the game. I've tried the "text", "physical keys" and "down" outputs.

Are the keystroke outputs showing up in the MT Pro log window if you check “outgoing” at the bottom of the log window?

Yes, they are showing up in the log window, in windows notepad, in Flight Sim but only in certain text fields that accept a certain type of text input (not sure how those are different), but not in the actual airplane in the game.

FS must be somehow overriding the standard windows drivers unless it is focused on a text box. If you try injected keystrokes and click on "“Capture…” on the Keystroke Outgoing action while floating your mouse over FS, does FS show a green box around the application or any controls within the application?
If so, then maybe click and then try to send the keystroke that way? Not all applications accept injected keystrokes however.

I tried injecting and indeed, FS windows had a green border but it didn’t work.

Hi did you try mapping to a different keystroke like maybe the F12 key that uses a single key? Or any other single key that you are not using. This would be a temporary measure to see if it is a driver issue or a timing issue.

Yes, I tried to map to single keys, no luck.

Hmm, I’m fresh out of ideas. Like I said, some games insist on accessing a physical keyboard directly and do not like talking to a virtual keyboard.