keystroke num 1 not recognized


I'm using a numerical keypad to change midi channel on my seaboard block. Everythings works just fine except that the "Num 1" is not recognized as Num 1, but as insert.

I've tested my keypad on different applications, and it is only in Midi translator Pro that it is not recognized as the correct key.

I didn't find an other way to put the keystroke into my little script.

So I don't know what to do in order to get that " Num 1 " keystroke.

Thanks for your help.

Hi, are you on a Windows Machine? Are any other “Num” Keys recognized? What language is your keyboard? I’ll see if I can reproduce. Also see if this article helps:

I’m on a mac, and it works very fine with the other num key. For now I use the « Zero » key instead of the number 1.

Here is my BMTP file.

My numpad is this model :


Also, my Num 1 key that have trouble with midi translator pro is recognized in any other programmes, including software that analyze keystrokes.





I was able to duplicate this with my Logitech extended keyboard attached to my MacBook Pro.

When entering Num 1 into Keyboard Maestro, or Apples Keystroke evaluator tool, it appears as Num 1. When entering into Bome MIDI Transport it appears as Insert.

I’ve filed a bug report as I believe the scan code recognized in Bome MIDI translator is incorrect. My guess is it should still work but not display the correct incoming keystroke.

Thanks for your patience while we work through this!


Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist



Ok, thank you very much !

By the way, I have something very strange happening with my script. When I change a midi channel by entering a number, I have to wait a little bit before I can change another midi channel (something like a second).

If I try to change without waiting it doesn’t work … Do you know where it could come from ?

Thanks !

Could you post your script? I will have a look. Nothing jumps out at me though.

It’s in my precedent post, in an attachment.

OK, I’m not seeing any delay here. You may want to check to ensure that BMT is not the active application when sending computer keystrokes. By default MT Pro will ignore incoming keystrokes when it has focus. You can change this behavior in Preferences->Options.

You are, however setting a 1 second delay on initializing global variables when opening the project.

Also, I just confirmed that although MT Pro reports the wrong keystroke, it will still work.

Yes I know I have a delay on initializing global variable, but it shouldn’t be a problem for when I change preset ?

Also this is a script that I load in one of my bomebox with the latest firmware (updated yesterday).

I’m still not able to duplicate the problem. If you are still experiencing it, could you turn on logging with MIDI IN MIDI OUT, rules and timestamp checked and show me what it looks like in the log when you are having the issue?

Thanks, I’m having the problem on the bomebox, not on Midi Translator Pro on my computer. I put it aside for now (I miss time), but I’ll do some tests later on.

OK, well you can use the MIDI router on BomeBox to route a given port to a Network Port on your computer so that you can read the log in MT Pro while you are running your project on BomeBox.

Also, if running on BomeBox, make sure your keyboard is on a USB hub. I don’t think they are supported if not using a USB hub.

Thanks, I tried with a usb hub and I have the same results. It’s ok for me now, because finally I use Lemur on my android phone with usb over midi, and that’s great, I can have feedback on the phone (that I couldn’t have with the numpad).

OK, let me know if it becomes a problem. It doesn’t surprise me that same problem on BomeBox as MIDI translator uses the same engine. I’ll have to also test on a PC but at least the developer is aware of the issue.