Keystroke to Midi (DAW)

Hi, new to Bome ProI. I want to send midi note messages to Cubase via Keystrokes, have set up a patch with all the requisite connections as per your directions in another thread, but the commands reach Cubase unaltered. I am suspecting the port routing is at fault, have tried all possible configurations, but no dice. Thanks for any pointers


OK, this is what I did:

Took away all MIDI assignments from input ports since we are using input from Keyboard and not MIDI.
Assignments for keyboards work on any attached keyboards.

Removed all output MIDI assignments except for 1 (Bome MIDI Translator 1) so that we don’t have multiple MIDI messages going to the same
application (since the Application is looking for all ins).

Removed MIDI default routes. No incoming MIDI so don’t need a default route.

You should ensure that MT Pro application does not have focus so that incoming keystrokes are not suppressed.

You can change this behavior in View->Settings->Apperance. See attached screenshot

Also it is important that your application NOT have focus if you don’t want it to see the original keystroke. Original Incoming computer keystrokes are never suppressed by MIDI Translator Pro going to the Operating System and applications (except MT Pro itself).

I suggest you set input of Cubase to Bome MIDI Translator 1 only.



thank you.
I will continue working with your template, but you suggest a few points that seem to undermine my regular agenda:
-If my application (Cubase) is *not* in focus, the window with the Plug-In GUI disappears, removing optical evidence of the commands being executed (in this case, I am trying to trigger articulation changes for strings). What’s more, as soon as I operate within that plugin, Cubase automatically comes into focus. Surely I misunderstood?
-by the same token, setting the midi input in Cubase to MBT1 only precludes my playing that actual instrument while I send the commands.. ?
I suspect I am missing some basic points here, and I thank you for your help again. Have perused the basic tutorials, but could not find anything on that specific topic.

update- using your template, I now got it working, I found out via Cubases own midi monitor that the command was sent an octave lower than specified by me, a problem you mentioned elsewhere and that is easily remedied. Thanks again!

Glad you got it working. Yes if the application is in focus (on top) but not the currently active application, it should work. Also, pick keystrokes that have no meaning to the application when sending MIDI. You can have multiple MIDI devices on your application but just remember and specify where you want the MIDI message to go. Each device (or plugin) needs to monitor a different MIDI port.

Hi there, I am trying to modify this template to be “arrow right=sustain on” and “arrow left = sustain off”. When I try to type midi control number 64 into the field I can not. Reason for this template is to turn a blue tooth page turner pedal (sends arrow left and right over bluetooth) into a sustain pedal in Pro Tools as I have no keyboard or regular sustain pedal where I am. I know it can be done! Help?

Hi, and welcome to the Bome Forum!

Try the attached.
You will first be prompted for your MIDI output port you will be sending Sustain? I suggest Bome MIDI Translator 1 Virtual. In your application, it will probably show up under the short name of “BMT 1”.

Sustain Control-2020-12-15.bmtp (1.1 KB)

Note, the incoming keystroke will NOT be suppressed. Bome MIDI Translator Pro cannot suppress the original incoming keystroke.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: