Level meters wrong behaviour using Mackie Control in Cubase


I am using Midi translator to customize my Qcon pro G2 and Qcon Pro Ex using Cubase 11.5. and a late 2015 Imac. First of all, when I connect the controllers directly to Cubase everything works perfectly. I want to use Midi Translator between Cubase and the controllers. Before start writing any translators I created 2 virtual ports (one for the Qcon Main and one for the Extender) Then I connected them using the midi router as showed in the screenshot. I selected the corresponding virtual ports in Cubase for each controller. In Theorie everything should work exactly the same as when connecting the controllers directly (without Midi Translator) But I have some problems with the channel meters.

Sometimes some of the meters get stuck when stoping playback. They don’t move for a while and then suddenly turn all the way off. After this happens, sometimes if I move the transport bar in Cubase with the mouse (also, the keyboard or the controller itself) the same meters light up shortly indicating the same value they had before getting stuck. I used midi Monitor to check if there was some unwanted messages going to the controllers but I could not see anything. Mackie handles the vu meter data using the Channel after touch and I can’t see any AT messages going to the controllers when this occurs. Again, if I connect cubase directly to the controllers the Meters work perfectly.

Since I have my Imac for some years now and I had also some minor errors using other software, I thought it could be that it needed a fresh start. So I went ahead and did a fresh install of Mac Os Catalina. But sadly the meters behave exactly the same which make me think there is some kind of error using Midi Translator.

Does anybody know something about this Issue and how It could be solved? Any ideas would be highly appreciated !

Thank you!

Hi, this is very strange. Maybe in Cubase you have both the original ICON ports open in addition to the Bome Virtual Ports? Could you take a snapshot of your Cubase MIDI configuration? Also I assume that you are using Bome Virtual Ports and not IAC ports named Bome Virtual Port 1 and 2 and you have no translators enabled in your project file. Just to be safe, maybe I can also see your project file. I do some limited testing on my Mac. I have Mackie Emulation controller but not QCON. At least I could look and see if the Metering messages look right.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Hello Steve,

Thank you for the quick response. It is very strange indeed. It is driving me a little bit crazy :frowning:
The ports in Cubase are closed. I am using Bome ports and no translators. The Channel pressure messages look right in Midi Monitor, but the controller’s metering reacts weird when connected to Bome.Screenshot 2021-05-12 at 16.54.17

Mackie.bmtp (1.1 KB)

Try closing your Mackie Monitor and instead look at the messages in the Log window of Bome MIDI Translator. Maybe if both Mackie Monitor opens a port and MT Pro opens the same port, there is some strangeness happening. In general it is not a good idea to share MIDI ports for this reason.

If this doesn’t help things, try creating 4 IAC ports (2 for in and 2 for out) and then instead of Bome Virtual Ports, use the IAC ports and see if you get the same behavior.

I’m not sure why BMT 1 shows inactive of your Cubase diagram? Generally this means some other application has control of that port.

Have you only defined one Mackie MCU device in Cubase? Also, I don’t remember what In “All MIDI does” in Cubase. Did you try changing that?

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Unfortunately the error continues with midi monitor closed. I created the IAC ports as you suggested but I get the same behaviour. About your question on BMT 1 being inactive: I took the screenshot when testing only one of my controllers to see if anything changed1. That’s why it was inactive at the moment. The “all midi option” is just to avoid controllers triggering midi instruments and so they won’t appear in the midi inputs inside the midi/instrument channels.

I spend today a lot of time trying to get to the error but could not find anything wrong with my settings. I also installed the demo version of Max 8 and created a quick midi In - Midi out routing using the same two IAC ports and I can confirm the meters are working as expected. That leads me to think that there is some kind of problem between the Qcon and BMT. But I am out of ideas what else to try

I came with a solution but it is not elegant at all. I created a preset that activates when cubase stops playback and inside this preset I filter all channel Pressure messages coming from Cubase. Then I send the corresponding reset values for the meters using a timer and sending the values continuosly for 200 milliseconds. Seems to work stable but the problem with this solution is that the meters reset instantly and doesn’t look too smooth. It should work if I am only routing midi from Cubase to BMT and from there to the Qcon. I would be more than happy to help finding out more about this error. What would be the next steps?

Hi, we are looking into it. Please bear with us while we check for other ideas.

OK, will do.

Can you capture a log with MIDI Monitor while connecting directly, and also with MIDI Monitor through Bome MIDI Translator so that we can compare the output. You only need to capture until the first problem occurs or maybe just a little longer.

We should then be able to compare the output and see what might be happening. If there is an option to capture the timing of these messages in MIDI monitor, that might help also.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz