MIDI clock to synth

Simple project for now, starting from scratch:
MIDI clock from Logic should go via BomeBox to a hardware synth. When I directly select the synth in Logic, clock goes through. When I set the router in MIDI Translator, it works also. But it does not work via the software Translator nor through the BomeBox with the loaded file.

I’m puzzled. The MT file looks ok, just one Translator. Bome Network looks fine too. Please look at the screenshot below. What can go wrong in this single simple Translator? Which part of our planet do I have to restart?

Hi, there are two ways you can do this.

  1. Create a translator with Timing Click In from Logic and Timing Clock out to Typhon
    This will allow only Timing clock through the path unless you have other translators that allow other MIDI messages.

  2. Create a MIDI Thru path from Logic to Typhon
    This will allow all MIDI message through that are not otherwise blocked by a given translator using the “Swallow” option

The below example has both methods but you should select one or the other.

First of all I created aliases and set up a MIDI thru path. This is a handy way to re-define ports if you move your project file from a computer to BomeBox or to other computers.

You can view the tutorial on aliases here.

I deactivated the preset so that all MIDI message will go through (Method 2)

Note that I have my aliases pointed to different locations because I do not have your gear.

For method 1 you will need to delete the MIDI thru path and activate the preset as shown:

Note also that I have limited the input and output path in the preset. You can find out more about device selection reviewing this tutorial.

And finally the project file using method 2.
MIDI-Clock-Path.bmtp (949 Bytes)

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

The Translator doesn’t work.
Strange. I have 5 USB target devices for timing clock on the BomeBox and 1 device on the DIN connector. 2 of the USB devices refuse the clock coming from the Translator. Both are synths (Typhon and Blofeld). Everyone else is happy. CCs and other events work for all devices, only the Timing Clock makes the problem.

Sending the clock from the DAW directly to the synths (which works) was my plan B. But then I have multiple parallel clock streams from the DAW to the BomeBox and there is also an additional controller on the BomeBox that can send MIDI clock. I would like to use this one too, but it has the same problem via a Translator.

Ha! Am I getting you right?
I can make a router path to the synth and add a Translator with swallow that processes specific CCs – and the synth then gets nothing but the clock and the edited CCs? That would be exactly what I want.

I tried the above suggestions and ideas and found not the best, but a workable solution.

Here is the part of the setup we are talking about, where the two synths to the left did not get Timing clock while all others did. Clock can come from the computer or (while playing without the Mac) from the Gordius controller:


Here is the only way it works (almost):
Stored in the BomeBox is a MT file with one Translator that allows Timing clock from Gordius to all devices. Other translators handle PC and CC events. Furthermore I need Router paths from Gordius to Blofeld and Typhon synths. These are actually both of your suggestions. The DAW must send to the Gordius Controller and then all devices receive it (only through the controller, not when the DAW sends to Bome-Net).

Due to the Routing paths, the two synths now receive everything from the Gordius but this does no harm because of fixed MIDI channels.

Still one problem:
Timing clock from the DAW through Gordius works, but when I send Timing clock from the Gordius alone, the two synths don’t get it. I cannot figure out why that happens. This will become a problem if I need to sync the synths in the computerless setup.

Steve, have you ever experienced that two devices refuse Timing clock?
It’s not the additional USB hub in my setup – for testing I also connected them directly to the first hub with the same result.

Here are my Midi Translator settings for the timing:


Hi, and thanks for the detailed diagram.

By what you are describing, I question whether the Gordius is sending timing clock at all. Have you tested in in this configuration?

Gordius → BoimeBox MIDI DIN → Powered USB Hubs

And then without a project file running on the BomeBox, manually set the following paths

MIDI DIN → Blofeld
MIDI DIN → Typhon

And then a monitor path

MIDI DIN → Mac MINI via BomeNet → MT Pro with input BomeBox to Monitor that you can see MIDI Clock.

Do your synths have any LED indicators showing incoming MIDI activity?

As far as not allowing MIDI Clock, check your translators to make sure that anything looking for MIDI Clock do not have Swallow Set or Stop Processing.

For instance, if swallow is set on a MIDI clock translator and the translator completes, the original message will not go through the MIDI Thru pat.

Furthermore if stop processing is set and the translator completed, then all further translators down the list will not process anything. Stop Processing simply means to start again at the top of the Preset/Translator hierarchy.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Oh and remember to assign your aliases on your BomeBox correctly.


Another thing to think about is whether the Midi Clock is actually coming through through the Gordius from the DAW when connected or maybe it is coming through from the ethernet connection and Bome Network?

I checked everything you suggested, everything was ok and yes, the Gordius sends clock and all devices have indicators to show that.

Good news: The problem is solved
As so often, the solution was logical.

My other devices are effect boxes, if they see MIDI clock, they immediately follow and hold the tempo until told otherwise. But the two synths have built-in sequencers and they ALWAYS expect to see start/stop messages, not just the clock alone, regardless of whether the sequencer is running or not. The Gordius was not sending start/stop.

All I had to do was to tell the Gordius to send clock start/stop commands like the DAW does. Now the clocking world is in order again. I no longer need the static routes.

Thanks for your effort and I apologize for bothering you with an issue that was not related to either Bome Software or BomeBox.

Awesome, I’m glad you solved it.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz