MIDI controller stops working in Ableton when a new device is plugged in/turned on.

I am guessing I have something set up wrong here, and/or one of my cables started occasionally dropping MIDI signal and coming back immediately?

If I plug in a MIDI controller while my APC40 MkII is running in Ableton with these Bome settings, I have to reset Bome or reset in Ableton MIDI device settings (just click off, or on, or whatever, in the settings and it resets).


I should note, the device does not stop working when my Edrums are turned on, and the edrum port on bome is "closed" whereas the problematic JunoDS and DrumbruteImpact are "open" port state.


It is possible that Ableton Live is "Fighting" Bome MIDI Translator Pro for direct access to the MIDI device ports instead of using the Bome Virtual Ports. You need to make sure that you start Bome MIDI Translator first, then Ableton Live. Ableton Live will then probably try and capture the direct ports (if the devices have an Ableton Script). So then go into Ableton Live and have the point to the virtual ports instead. Then restart your Bome Project. If ports are added while this setup is running, Live will probably again try to go directly to the device port instead of using Bome Virtual Ports. Most Ableton Live Scripts are written this way. One you tell both Ableton Live and MT Pro the correct ports, it should continue to work as long as the ports remain open and stable. Again if you disconnect and reconnect a physical device, Ableton Live will then again try go to to the device port directly (unless you either disable MIDI remote scripts or re-write them). This is just the way Ableton Live scripts usually work. The script always tries to go to the direct port until you tell it otherwise to use virtual ports. Re-writing the remote script might also be a way to fix it but you would have to use a Python Decompiler, give the device port a different name and then drop them back in place for Ableton to recompile and execute them.

On Windows, it is actually a bit easier, because Windows doesn't share MIDI ports so if MT Pro starts first, and you have device ports open already, MT Pro will not relinquish control of the ports. I see you are a Mac though. If you are not using the MIDI Remote control scripts, then you can always move them to a different folder than the default Ableton Location and they will not try to load.

I have not found a better answer and it seems that with Ableton Live 10, things have started to get even more difficult.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz




Solved! Legend. Thank you, I removed everything except "ableton" and "APC40mkII" folders from MIDI Remote Scripts and we are good!

This didn\'t actually work.

What did work is in Ableton, in the list of devices, add your other MIDI controllers ahead of time with them set to \"None\" under the Control Surface column and they won\'t steal remote control (just straight up crashing it until you power the APC on/off, flip a setting in ableton remote control settings, or reset bome.

Before, I didn\'t have them added to the list, only the APC/Bome.