MIDI incoming delay/lag across 2 machines when using MIDI controller


First time poster but have been using bome for over a year now on projects. I travel with 2 BomeBox’s and for the most part have been a set it forget it solution for a majority of my projects.

My projects with BomeBox’s have been very basic 8 midi faders which get adjusted but not intensely. BomeBox has been a solution to distribute 1 MIDI signal across 2 machines.

Have an upcoming project where more than 8 faders + buttons + pots will be used by a VJ (visual jockey) during prep for this project i tried some stress testing via the BomeBox and have found an issue where when I try to fade 4 faders up and down fast the MIDI across the network delays.

So when my physical faders are down the visual software completes this action maybe 0.3s later. When its 1-2 faders its not noticable.

When i disconnect a 2nd machine (I havent found a difference between disconnecting the windows or mac) the stream is perfect when i reconnect and have 2 total machines the issue is present.

My BomeNetwork software is: 1.6.0 windows + mac
My BomeBox firmware is: 1.5.4 (76412) across both BomeBox’s
I use static IPs with a subnet
My BomeBox I have powered over micro-usb and tested from PC USB power and currently last tested via a phone USB phone charger. I havent tested with PoE.
I have seen this issue present with a: nanoKontrol2 and a Novation LaunchControlXL
My MIDI devices are over USB only.
I have tried a factory reset on one BomeBox
I have WiFi disabled
My BomeBox’s are labeled as BomeBoxOne then BomeBoxTwo
I have 2 MIDI routes only: MIDI → machine 1. MIDI → machine 2
I have no MIDI translator
I have seen this issue present with 2 different bits of software recieving MIDI
I have tried going: BomeBox ETH 1+2 pier to pier. (ETH 1 to Machine 1, ETH 2 to Machine 2)
I have tried going: BomeBox ETH 1 → Unmnanaged switch
I am using Cat6A cable. both machines were coming into a switch as 1gbps where as the Bome was coming in as 10/100mbps
MIDI to Machine via USB doesnt have this issue

When testing I have tested with 2 windows machines and a mac. Currently my home setup is 1 windows 1 mac where this issue is present.

Am I missing something here or am I doing something wrong? Is there anything else I should look at?

Any help would be greatly recieved.


Hi Ben,

Sorry for the problem! Welcome to the Forum!

You mention you have 2 BomeBoxes connecting to 2 computers. Are the both sending to both computers simultaneously or are you only sending from one BomeBox to 2 computers when you have the problem. If two BomeBoxes to two computers, what is to stop them from getting duplicate messages?

I think I have most of the configuration that you have so will try to duplicate your environment but not sure whether to try it with one or two BomeBoxes and if two, how the controllers are set up (which controllers on which BomeBoxes) and how your routing works.

nanoKontrol1 → BomeBoxOne → Machine1
---------------> Machine 2
LaunchControl XL → BomeBox2 → Machine 1
|------------> Machine 2

Are you using Remote Direct MIDI on your machines or just using to the main network MIDI port?

Have you confirmed that you don’t have any duplicate IP addresses (since you are using static IPs)?

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Hi Steve,

Thanks so much for the fast reply.

My fault with the two BomeBoxes I am only ever using one in this system. I have attached a crude schematic of what my current setup is.

‘Are you using Remote Direct MIDI on your machines or just using to the main network MIDI port?’

I’m using the BomeBox MIDI over the network so I have no local MIDI devices connected to either machine. My goal is to make the BomeBox is responsible for this. If thats what you meant? Screenshot of my routes attached

Also my MIDI ports: I am only using the one USB port on the BomeBox with no USB Hub so im not sure if the [2] is something to look into?

My IPs from BomeBoxs POV (just to prove to myself I havent had any duplicate IPs!)

I dont know if this means anything. On both BomeNetworks Application they are both sharing the same Virtual MIDI port:

I will keep looking over now and just triple check everything.

Thanks again

Thanks for this.

I found a delay if I used MIDITools and turned on log messages on my Windows machine, however if I turned it off, the delay went away.

Are you using this feature when you see the trouble. It is best to turn all logging functions off as it is possible the logging itself will slow things down.

I looked at the physical fader movements to detect the actual delay (by eyeball).
There was a real notable delay when the other logging window above was running.


I tested with Launch Control XL through 1 BombeBox to Mac and Windows PC.

Turning on the log Window in MIDITools on the Mac didn’t seem to cause any problems on my Windows Machine but there was a delay in the logging although the faders kept up just fine on my Windows PC but slowed down on my Mac.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Thanks Steve for deep diving into this,

Ok, This looks interesting. I dont do alot with MIDI audio wise so MIDITools I dont have. The only software that I have which is close is Bome MIDI translator Pro Trial. However, Im not running this and I have set it so this does not run on my machine startup.

The software which im using is Resolume currently testing with 4 layer faders and is still present.

Theres no logs within the BomeBox that would cause anything similar to what im experiencing?

It happens when I am connected to both but not when im connected via one but whats interesting is if im connected to a machine via the BomeBox but connected the second machine via BomeNetwork to MIDI chase the first machine it doesnt happen.

There is a verbose feature of MIDI Log in this new version but it still doesn’t log individual outgoing MIDI message.

I’m not familiar with MIDI Chase. Is this another application? Is this the other application you are trying to connect on BomeBox?

So I’m hearing if you connect to both applications directly via BomeBox, things slow down, but if you connect only to Resolume from BomeBox and then use your PC to forward the message on to another computer via Bome Network, it doesn’t slow down?

I’m testing with an instance of Ableton Live on my PC (using MIDI remote script) and Ablelton Live on my Mac (using MIDI learn)


Thanks Steve,

MIDI Chase was my way of describing the setup of: BomeBox → Machine 1 → Machine 2 so rather than using the BomeBox to send to 2 sources it sends to one where the 2nd machine is connected to machine 1 for its MIDI.

‘So I’m hearing if you connect to both applications directly via BomeBox, things slow down, but if you connect only to Resolume from BomeBox and then use your PC to forward the message on to another computer via Bome Network, it doesn’t slow down?’

Yes exactly that.

Iv deep dived a little bit more from last night. So I have downgraded and upgraded the BomeBox to a few different versions. FW and SW version 1.4.2 its still present but not as bad.

My current setup is now using 3 machines and iv removed the bomebox out of the mix. Machine 1 and 2 are recieving MIDI from Machine 3. Machine 3 has the MIDI controller plugged in. The issue is not present with this setup. Which makes in my mind the physical BomeBox the problem. But saying that it seems odd that it would but the majority of my use cases have been no where near the amount of traffic sending over the network as what im needing to do now.

Same IPs, Same subnets, this time using a 8-port switch to manage the traffic rather than the BomeBox.

I’m going to keep trying some ideas with the BomeBox but this really has me a bit stuck with the BomeBox

On each of your machines with your BomeBox connect. Click on the BomeBox name and see if you have any green switches on for our Remote Direct MIDI ports. If there are any switches on as shown here in the illustration, turn them off. Then see if that helps.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Ok, All of these DIN switches are disabled and still no change with 2 machines.

I did some more testing earlier and had 2 MIDI controllers connected to the BomeBox. 1 MIDI controller going to machine 1 then the 2nd MIDI controller going to machine 2. This lag/delay wasnt present only when its the same MIDI controller is it present.

I also used MIDI translator Pro to create a default patch (USB 1 → Network 1 + 2) just as a random idea and still no change.

Iv excluded other networks that arent needed so only my 10.x.x.x range is being used, disabled wifi on all machines just in case and still no change. I have a 3rd machine now running windows so I have tested windows to windows with no luck.

I know you have static IP address, but is there also a DHCP server on your network?

Thats a very good question.

There 100% shouldnt be across my machines but I cant 100% confirm that. I will look into it now.

If there is a DHCP server or something broadcasting / multicasting would that have the potential to cause these lags/delays?

Yes, a DHCP server running on a static network could do that if the DHCP addresses overlap the static ones you have assigned. It could cause all kinds of other havoc as well. Typically I use DHCP for everything and if I need a static address, I makes sure my DHCP server does not allocated addresses in that area.

I’m still trying to duplicate your issue.


Ok, Thanks Steve.

So, I tried to isolate my machines the best I can however this setup isnt going to be the one used so I wonder if im going to chase my tail when I dont need to on this setup.

I will be with the real setup in 2 days time.

Some more playing around, iv found this issue isnt present with the nanokorg but is with the controlXL. Same patch, setup just swapped the USB into the BomeBox with the controlXL with the nanokorg and issue is present with controlXL but not nanokorg. Iv only ever used the nanokorg in my setups.

Your suggestion of disabling DINs alongside everything else is probably needed. I briefly tried a pier to pier last with the actual machines and this issue was present then which caused me to investigate more this week at home. However, That could of been because of the DINs or needless patches within my BomeBox.

I think The Launch Control XL takes more power so that could be the problem. Not sure why it would work OK when connected to only one host, but maybe the second ethernet port draws a bit more power from the BomeBox.

I use POE to power my BomeBoxes. It is more reliable for devices that consume a bit more power.

Last time I checked my Launch Control XL consumed 230ma and most other devices were closer to 100ma. The real pick is the Launchpad MINI which consumes 500ma. My nanoKontrol2 doesn’t even register on my tester

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Thats interesting to know. Thanks Steve.

Iv recorded a short video trying to show the issue im having hopefully its showing a bit more than what iv sent across already in the form of screenshots and reports. I know lag and delay can often mean different things. The BomeBox is definately usable but when put under ‘load’ it has these delays and with getting different results from different midi controllers i know its probably made this report a bit more confusing…

link to video: https://youtu.be/KHQWyR9RJTo (just uploaded so should be HD soon if not already)

03:44 - good example
03:55 - good example
04:40 - good example


I can see the issue. I’m just having problems duplicating it here.

Question. Is Resolume only opening one MIDI port from your APC-MINI on each machine or are there other MIDI ports open as well?

Can you load MT Pro (trial if you don’t own it) on each machine and see if you get the same lag as you are getting with Resolume by monitoring the input using MT Pro?

Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Loaded MTPro and with Resolume closed the issue is still present monitoring the bomebox MIDI input.

Resolume is only detecting the BomeBox as a MIDI device. Not using the remote direct MIDI so just shows up as the BomeBox rather than any MIDI controller name and within Resolume iv only enabled MIDI Input not output.

Its been present across both of my BomeBox’s

OK, still looking into it.


Does your MacBook have a direct ethernet connection or are you running it through an ethernet to USB adapter?


For my MacBook I am using a USB to ethernet adapter. type-c to Ethernet.

Both windows machines have ethernet cards.

It’s a good point and I can’t remember if I have tested it between my 2 windows machines.

I am with the actual machines today so no longer with my home setup. so will update here shortly about what I find.