MIDI port may be in use by another application

Hi there,

I'm not owning any Bome product but come here due to a forum post from 2018 concerning MIDI ports not opening in applications.

I have a brand new PC (AMD Ryzen 5 3600, 2 SSD's for system+Samples, etc. which is quite powerful) with Win 10 Pro, Native Instruments Komplete 12, Steven Slate Drums 5.5, Jamstix, Studio One 5 Artist, Reasonstudio 11, Jam Origin MIDI Guitar. My interface is a Focusrite Scarlett 6i4 and I have a Nektar LX88+ MIDI keyboard/controller (works fine through USB) a Novation Remote SL Zero (haven't set it up yet ...), a FCB1010 connected through my Scarlett's MIDI ports and a BCR2000 connected via USB (doesn't work anymore).

All my gear is functional (worked until changing PC on a Win 8.1 machine) and when I installed my music software 4 weeks ago. I'm sure that my BCR2000 still worked back then.
Since a couple of days I get the message "MIDI port may be in use by another application" when I try to open the BCR MIDI Port 1 (or2,3 for that matter) in Reason. Studio One just says "couldn't open MIDI port for BCR2000" or something like that, NI Komplete Kontrol sees the MIDI ports but can't tick/activate them.
I've found a couple of hints with a Google search, none of them made a difference. Uninstalled/reinstalled the BCR drivers (64-bit, 1.0.10 multiclient, last driver from Behringer) to no avail.

What I did see however is that some application must have installed something related to BOME. I do have a Bome folder in my programs (or Windows) folder and I think I might have seen a Bome service in Windows services.

Is Bome software part of one of the aforementioned applications?

I'd be very grateful for any help or insight.



Well we know something is using the port, we start with trying to figure out what. I assume you have closed all of your MIDI related applications and then tried opening the BCR2000 port.

I believe NI has OEM license Bome Virtual Ports, but as far as I know, they are only used when a NI application is running. You might want to check with them. However even if they are being used, you would only get this error if something else was trying to access your BCR physical port.

If you are running something like BCR manager at the same time that you are trying to use it with other applications, this could be problematic.

Bome Virtual ports do not run as a service. They are controlled by starting and stopping the Bome applications (addressed below).

I had a similar issue some years back and found out that after loading a program called "CopperLan", I could not access many of my MIDI ports. Apparently this application takes control of all available local MIDI ports so the only way you can open them with an application is through one of their virtual pipes. I de-installed CopperLan and my problems went away.

Again on Windows only 1 application can access a given MIDI port (virtual or physical) at a time.

Bome has two ways of addressing this.

  1. With Bome MIDI Translator Pro, you can access the physical port input and then use the MIDI router to split to two virtual outputs. Each application can then access it's own virtual port with no conflict. (Reverse the process for routing back to the original device. You can test this with the trial copy of Bome MIDI Translator Pro (MT Pro).
  2. Bome Network Pro has an add-on feature that does similar called "unlimited virtual ports". This feature is currently in public beta. Use the contact form if you want to give it a try. The difference here is you can name your ports anything you want (that isn't already being used), however if you need translation of MIDI, it doesn't cover this (that is what MT Pro does). This product does have advanced MIDI routing features however which can be accessed from the Bome Network application ICON in the system tray.

So in a nutshell, shut down all MIDI apps at a time until the MIDI Port conflict goes away.

If you want to share MIDI ports among applications, then use one of the products above.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Hello Steve, 

thanks a lot for taking the time to answer.

Well, I'm in this DAW game since almost 20 years. Generally I do know fairly well what I'm doing but I'm really at a loss here.

Might be wrong for the Bome Service, not at home on my PC right now.

There's nothing else running or connected to the BCR. Like I said, it's a brand new installation and I can manage configuration tasks for my controllers on a laptop. I want my system as clean as possible ...
I haven't installed any virtual MIDI (loopback)ports/routers either (for now).

It seems like no application can open the MIDI ports for the BCR right now, bummer. It worked a couple of days ago.

I've done some further research and across a Microsoft article, maybe it will be helpful (to someone esle as well), I'll see tonight when I get home.


I'll report back as soon as I get it working or have other questions. I might as well have a look at Bome MTP, I'm hearing praises for it since years ;)



This gave me an idea. Close your web browsers and try again.  Some web application now access your MIDI port remotely, especially Google Chrome.


I ran into this when programming my MIDI Baby footswitch. Evidently the browser took control of the port and I had to close it to re-gain control.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services: bome@sniz.biz

Will do Steve.
Appreciate your help ;)

Well, I tried a bunch of things to solve this problem. Uninstalled all hidden devices in device manager (after turning on everything that could potentially be in use on this PC), uninstalled/re-installed the Behringer drivers.
Opened only one application at a time (no browser, no Windows explorer nor anything else), still the same, no single DAW can open the BCR MIDI ports ...
There's a video on youtube about a registry entry (ksthunk) which didn't change anything. In fact the entry was already present.

Tried changing USB ports, to no avail.
Funny thing is, all other USB devices are perfectly recognised and functioning.

I'll try to revert to a prior system state by means of Windows restoration points when I get back home ...

Maybe try to uninstall any MIDI Drivers and use the Windows Drivers instead. You said you have a custom BCR driver?

Hi Steve, not a custom driver but the official Behringer 64-bit driver.
If I feel lucky, I'll reset my system in a couple of weeks, don't have the time for it right now.
Plus I'm in the middle of a project ...

I'm giving up for the time being, having other controllers that work.

Appreciate your help, really do. Thanks a lot.

Raphael ;)

You wouldn’t happen to have a Korg MIDI Driver loaded, would you? If so, please uninstall it. I’ve run into conflicts with this driver before and the Windows driver works just fine on my Korg equipment. Same for Roland.

Indeed, I’ve got a Micro X but don’t think I installed their shitty driver.
But will check on that :slightly_smiling_face: Thanks for the hint.