Modal Craft/Skulpt don't detect


I've got a Bome Box and two Modal synths, the Craft 2.0 and the Skulpt. The Bome box won't see either one of them on USB, with or without a hub, but it sees everything else I've thrown at it just fine. I'll follow up with Modal as well, but I'm wondering if anyone else here has run into this?

Got word back from the Modal side — they've never seen this before, but they haven't tested with a Bome box specifically.  I'm not seeing anything in any of the logs, including the kernel log that should be showing the hotplug event when I connect it.

Hi, according to some web links I looked at , they should both be class compliant.   I assume you are trying to see them on your BomeBox itself as they will not show up as separate devices on a connected network port.


It looks like the Skupt has 2 USB ports, one for power and one for data. I assume you are connecting to the data port.


Steve Caldwell




Yup, they should both be class compliant, and yes, trying from the BomeBox directly, both with and without a powered hub — the Skulpt comes up just fine and works normally, but no enumeration. The Skulpt only has one USB port.

The Modal engineer I'm talking to has dropped an email to support@ and info@ — if you have a chance to connect with them, that would be great.

Maybe if you can copy the BomeBox Log. And a screen shot of the devices it shows.  I can pass the log on to someone who might be able to figure it out.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Here's a copy of the bome log, the system and kernel logs, and all the devices it's enumerated. The only thing missing from the connected hardware is the Skulpt. (And yes, I know they're all showing closed; trying to sort this out before I set up routing)


Can you show me a screen shot of the devices page?


Also, do you have a bluetooth USB dongle attached?


Here are screenshots of the devices. I also cut and pasted the text from that page into the file I already uploaded. Note that I've got the Skulpt connected by DIN on the connected interface here, which does work for the time being, but doesn't answer the question of why it doesn't work on USB.


And no, no bluetooth.

Sorry to ask for more but could you connect only 1 device directly to the USB port without a hub and then show a screen shot? If possible, do this for each device. Also, I'm seeing a request to mount /tmp/run/mountd/sda1 which looks like it might be a storage device. Do you also have a USB thumb drive attached?

My BomeBox shows nothing about this type of mount request.


Finally, please let me know what version of BomeBox FW you are running.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Here's a screenshot with just the Blofeld plugged in, and another with just the Skulpt (which isn't detected). The BomeBox is running 1.4.1; I'll try upgrading to 1.4.2 in a minute — hadn't noticed that it had come out. There are no storage devices connected to the system.

I tried rebooting it again a couple of times to get logs with and without the USB hub (and all the devices) attached; I don't see the sda1 mount failure in these either time now, though, and no apparent behavior change.


No change with 1.4.2.

Is there a setting on the device to choose whether to send to MIDI DIN, MIDI USB, or both? On some devices, if you have MIDI DIN selected, they will not show up on USB.

Have you tried hooking up to PC or Mac with USB?  Is the device detected there?

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi! The device works just fine with USB midi from a PC, and with DIN midi direct otherwise.

Thanks, I’ve asked the developer/ownere (Florian Bomers) to look into the log and other information you provided. I don’t think I’ve ever seen a BomeBox not recognize a working class compliant USB device.