Mouse Button Clicks in Bome MIDI Translator

Hi, I have a problem with an Outgoing action in the translator.

For my project, i want to move the mouse to a specficic area of the screen, and left click there, from my midi controller.

But the "Mouse Button Clicks" option doesn't move the mouse to the area I specified in "Set Mouse Position", it just only clicks where my cursor is at the moment.

I tested the "Mouse Position" and it works with my MIDI controller, so I don't understand why it doesn't with "Mouse Button Clicks".

Or maybe i didn't understand the fonction of "Mouse Button Clicks"...

I'm on Mac OSX 10.11.

Thank you


Hi, I’m not running on Mac but I can certainly look into it on Windows if you think it will help. I know there are some differences between what BMT can do on Widows vs. Mac.

I just tested on Windows and it worked as I expected. Not sure it helps though since it is on Windows 10.

Here is a snapshot.


Here is a snapshot of the click settings I had on the previous screenshot.


Also in the manual please note.

“You can emulate button clicks for left, right, and middle buttons as well as
for auxiliary buttons 4, 5, and 6. It depends on your mouse settings what
they will do. For example, the 4th button is often mapped to the “Browser
Back” function, and the 5th button to the “Browser Forward” function.”

So maybe check your mouse settings.

You\\\'re not trying to click on a secondary monitor are you?


Thank you for this quick answer! I have the same type of settings, no it doesn’t work for me.

But for now, I just realized that I can create 2 translators that follow for the same incoming action from my midi controller. The first moves the mouse, the second clicks… I guess it’s ok for my project… Note that i just got this application as a demo to see if it can helps my project, i’m not familiar enough with the app.

I let this topic unresolved, maybe it’s a bug linked to the Mac OSX version?


No it’s on my single monitor. Same type of setting for me as yours. I notice that on my version there is no ”Capture” button for the position of the mouse. Maybe OSX version is not as advanced.

Yes according to the manual capture capability only works on Windows.

so mouse movement works, but not movement+click?
Mac OS 10.12 brought a few problems similar to the one you’re describing but we weren’t aware that they also apply to 10.11. Maybe Apple introduced the same kind of incompatibilities with an 10.11 update? We’ll be releasing an update with the fix soon.

Yes exactly.
So maybe an OS update brought these problems.

working on an update? still not working with 1.8.2 on Mac OS 10.11. Would really appreciate that feature

Puya, mouse click emulation should work fine with 1.8.2 on macOS 10.11 and 10.12. Can you describe in more detail what is not working, and at best post your project file?

I don’t know if this will fix your issue. I’m on a 2018 MacBook Pro running Mojave (OSX 10.14). I was having issues with controlling my mouse. I searched the internet for hours. Anyways the problem turned out that I hadn’t allowed the application to control my computer via the security setting in the system preferences. It might help. It sure did wonders for me.

Midi Controller – Behringer X-Touch

MacBook Pro 2018 OSX 10.14 (Mojave)

Input – F1 Button down; Output – Mouse left button down

Input – F1 Button up; Output – Mouse left button up

Thanks, I hope this helps!!!

Good to know. Thanks for the update!