Mouse Movement with MIDI Key Presses Glitched Out

I didn't know how to explain this fully in the title, but basically I'm trying to set-up a file (attached) that allows me to play the game Minecraft with only my MIDI keyboard in place of both my computer keyboard and mouse. I have got the keyboard controls working perfectly, as well as the clicking functions of a mouse, however I cannot quite figure out what's going on with the mouse movement.

I am attempting to use two keys (B4 and F5) to nudge my mouse position 100 pixels to the left and right respectively, using the Mouse Movement outgoing action. In a similar way, I'm trying to use A4 and G5 to move the mouse position down and up by 50 pixels. (I'm only trying it this way as I'm not sure if there's a way to hold a keyboard key and have the mouse move in a certain direction until I release the key. If this is possible, please let me know as it would be much easier to work with!)

The 'glitch' that I'm having with using the keys to move my mouse position is that no matter how many pixels I tell it to move (even zero), it move my cursor an entire screen length to the left. This is the same for the up and down movements as well. It just shifts my cursor roughly 1920 pixels to the left. I am running a triple monitor set-up with the middle being my primary, so it shouldn't be an issue with trying to use it on a secondary monitor. Any time I use the mouse movement action, this happens no matter the direction. And it always shifts the cursor until it hits the left side of my left monitor. As for in game, no matter the size or direction of movement, my player immediately faces downwards and rotates facing downwards every time I press the key. It's very, very weird.

I have no idea how to fix this and just get it to actually move a correct set amount of pixels. If anyone has any idea on how to solve this or has a good work around, that would be greatly appreciated. Once again if it is possible to just hold the keys and have the mouse/in-game camera move until the key is released, that it also an option I'm happy to use. Thanks!

FYI I'm using Window 10, each monitor is 1920x1080, and my graphics card they are connected to is an NVIDIA GeForce RTX 2070. My MIDI keyboard is an M-Audio Oxygen 61. Not sure if those specs help but there they are!



I assume the translators with issues are 0.10-0.12. These all work on my Windows 10 PC.

I know some video drivers use a set up that controls which monitor you are on (other than Windows). Maybe there is a mode you can set on your NVIDIA driver to allow Windows to manage the monitors instead of the NVIDIA driver. Managing multple monitor support for MT Pro happeded with version 1.8.4 Is that the version you are running? Also make sure it is at least build 962 as I think there were some positioning issues with the initial 1.8.4 build.

For the attached, I just duplicated your 3 translators then disabled the original and changed the input device and notes for my controller and it seems to work just fine.

Demo Video

Steve Caldwell

Bome Q and A Moderator and

Independent Bome Consultant/Specialist



Thanks for the super quick reply and demo video! I don’t believe there is a way to allow only Windows to control my monitors, however I have set the middle one as the primary one through Windows display settings too. I am on the latest version and latest build as I installed it yesterday, so it shouldn’t be to do with that.
As for your demo video, that’s extremely odd that it works for you and not for me! I see you’re using control change rather than actual keyboard keys with ’note on’ (which is what I’m attempting to do) but even when I use control change, it still doesn’t work. It’s very confusing.
With your first sentence, what do you mean by ”0.10-0.12”. Is this a setting that can be changed or something to do with my midi device?
Also one last thing, would it be possible to hold down a key to move the camera in a certain direction until I release the key? Like a note on/off type of situation with the output being rapidly repeated til I let go?
Thanks heaps, hopefully I can sort this out!

The 0 indicates the preset number and the 10-12 are the translators in that preset.

Yes you should be able to hold down a key to move the camera. The outgoing action should have repeat option turned on for the key and make sure you have a translator for key up when you release the key (note off).

I suggest you look on the NVIDIA forum for the issue you are facing with the video driver. I see other people are also complaining on how it handles things.

Steve Caldwell

Bome Q and A Moderator and

Independent Bome Consultant/Specialist


Ohhh right yeah I get you now, I was overthinking what you meant, my bad.

Would it be possible for you to show an example of how this would be done? I’ve tried finding the repeat option but I cannot find it unless my outgoing action is for a keystroke, which in this case it is for a mouse action.

And I will definition look into the NVIDIA issue. Thanks for the help!

Ah, for mouse action you will need to set up a timer in MT Pro to trigger the action periodically when your key is pressed down. It would look something like the attached.

Translators 0.13-0.15

When you press a key the global ga and gb are set to the relative mouse position that you want and a timer is started called "mouse move".

Translator 0.17

The timer is continuous and performs mouse move at the interval you set (currently 500ms or 1/2 second).

Translator 0.16

Then there is a translator to kill the timer when any of your mouse move keys are released. I'm using CC but you can use keys.

I'm assuming you are not using the global variables ga and gb elswhere in the project. If you are, then change them to something that you are not using.

Steve Caldwell

Bome Q and A Moderator and

Independent Bome Consultant/Specialist




Thanks so much! I changed the CC inputs to my keys, and created separate translators as Note Offs to cancel the timer but it still made the same glitch of teleporting my mouse a screen’s length to the left, so I disabled my left screen and kept my right two, and it worked somewhat! The left and up translators worked, but not the other two, so I disabled my right screen and only left the middle and it worked flawlessly! It must be an issue with how well Bome can handle multiple screens, which is understandable as that feature was only recently added. Hopefully that gives you a bit of insight on other things that could possibly be fixed in the future.

Now all seems well and good now, except when I go to play the game Minecraft with these new controls, the same issue happens with my player’s camera facing directly down and spinning around in circles when I press or hold the keys. I’ve tried decreasing my sensitivity to 1 in game but the same issue occurs. Everything else works fine though. I don’t suppose you have Minecraft to see if this issue occurs for you too? Completely fine if not, I’m just curious to see if this is just something with my computer or the game itself, as I’ve seen someone else do this kind of thing with Minecraft and not have a problem…

Nevermind!! All I had to do was enable ‘Raw Input’ in mouse controls in Minecraft and it works perfectly!! The only downfall is that I can’t have anything on my left and right screens while I play but that’s a minor inconvenience. Thanks so much for your help again!

So the relative movements only seem to work correctly on your primary screen?

With all three monitors enabled, it didn’t work at all. With my primary and right screens enabled, the up and left movements worked on the right screen, and only the up movement worked on my primary. With only my primary screen enabled, all movements worked flawlessly. That was, however, until I rebooted my PC today, only to find that each movement works fine across all three screens now… The right and down movements seemed slightly slower, so I just decreased the repeat for them by 1ms and everything is just as good as with only one screen enabled. I’ve restarted my PC again to see if it still works and it does. No clue why it didn’t work yesterday but does today but at least I know I can temporarily fix it by disabled my two other monitors. Not sure if any of this info helps you fix any bugs but it’s just what I’ve experienced! haha

Well it must have been a Windows video driver update thingie then.

Happy Minecrafting then.