MTP Stop Processing

Hi, I have a translator set up that ‘suspends’ MTP processing. Very handy when I just need to use the internet for a little bit and type things out. But it scarcely works. Sometimes it does, and sometimes it doesn’t. I just read that it could be rules that are still executing?

It’s strange because the spacebar doesn’t work unless MTP is suspended. But I don’t have any translator as the spacebar for an input. Same with ’ and ; They both move the mouse and click as if there is a translator executing, but I don’t have those keys as inputs in MTP. My MIDI Buddy modifier key is blank. It doesn’t have one, so it can’t be that.

The two programs don’t like to sit in the Windows 10 toolbar either. They always move back to the ‘hidden’ icons. I drag them onto the toolbar, then they stay there for a few uses, then go back to hidden.
And when right clicking them, sometimes MIDI Buddy refuses to open its menu. It just closes the ‘auto hid’ toolbar on me. ?

I’d have to look at the translator but keep in mind that Stop Processing only works if the outgoing action is triggered so if you have a rule in the translator like:

if qq==0 then exit rules, skip outgoing action

Then stop processing will not work.

If both exit and stop processing you would add a translator right after that with the same incoming action as the current one with an action of none and stop processing set.

MT Pro by default will suppress incoming and outgoing keystrokes when focused. This behavior can be changed in Menu View-Settings-Options as shown below. They are normally checked to prevent unwanted keystrokes from upsetting your workflow when developing an MT Pro application.


As far as MIDIBuddy modifiers maybe you have it set to a space bar instead of blank. Look at your MIDIBuddy.ini file which should be in the same folder as the MIDIBuddy executable.

You can change the behavior of MT Pro whether it lives in the toolbar or the System Tray by going to Appearance in settings.

MIDIBuddy is designed to only live in the System Tray unless a dialog box is open. You have to right click MIDIBuddy in the System Tray. Right clicking if you have a closed dialog box living in the toolbar will do nothing and in fact, you should not every have something from MIDIBuddy in the toolbar for normal operation ( unless you have a dialog box open that you are working on).

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

I have no rules in the ‘suspend MTP’ translators. Maybe Corsair’s iCue is intercepting them. I’ve investigated before and found no conflicts anywhere. I’m asking you because it’s inconsistent. Sometimes it works fine.
But if I ‘suspend hotkeys’ on MIDI Buddy, it works every time. (I just retested it right now, and that is what happened again). I know whether it has suspended MTP or not by my spacebar working or not. That’s another thing about the ‘suspend hotkeys’. It seems to render the ‘Suspend MTP’ function useless when its hotkeys are enabled. Remember my MTP mouse macroes not working unless ‘suspend hotkeys’ is checked (hotkeys disabled).

I know MTP suppresses incoming keystrokes on focus. The reason to have the ‘suspend MTP’ as a macro on my keyboard, is so I *don’t have to focus MTP. If I did, then I would simply push that ‘STOP’ button every time.
So this question isn’t that important, but it annoys me, as it should simply just work properly.

I checked the MIDI Buddy settings. In the notepad, there is nothing for the modifier key. I butted up the text cursor against the equal sign, and there is no space there, so there is no modifier key present.

I wonder if my special characters that I’m sending from iCue is being seen as spacebar (or other keys) by MTP or Windows? For example: ‘Suspend MTP’ input from iCue is F15. ‘Restore MTP’ is F16.

One of my mouse macro translators input is [VK 124]. Another translator is [Scan 121]. Another is F22. So these are abnormal messages. I was just wondering if you knew about it, before I have to go through each and every single translator to isolate the issue.

Ideally, I could get iCue to just send out MIDI messages and then MTP would see it as a MIDI controller. Then I would have unlimited space for making macroes.

I just like having MTP and MIDI Buddy sitting there in my toolbar. Just one less click when I have to ‘suspend hotkeys’ and ‘choose output port’. Which I shouldn’t have to do anyway.
Not a big deal.
Ideally, there would be a translator I can put on my keyboard that closes MTP, and then it closes MIDI Buddy with it. I think this was in my list of custom requests. I haven’t got the funds to commission that work yet.

Thanks again.

Hi VK 124 is F13. F22 is VK 133. Scan codes vary depending on keyboards and their supported drivers Essentially the keyboard driver take sthe pressed key (scan code) and converts it to a VK that is interpreted by Windows 10.

Having a layered keyboard driver that sends macros from your keyboard application can indeed change the behavior of anything else interpreting keystrokes in Windows 10. This includes MT Pro and MIDI Buddy, which just hooks to the currently loaded driver. I’m really not sure how iCue macros work so not sure if I can help you there. I know that if I use the Logitech Mouse driver with MIDIBuddy, things don’t work correctly as the Logitech Mouse driver also has a macro capability that interferes with the standard Windows drivers.

MTP closes with Control-F4 I believe but it will not automatically close MIDIBuddy. I believe the default to close MIDIBuddy is Control-Alt-Q so maybe you could put in a translator that sends Control-Alt-Q and then another one with the same incoming trigger that closes MT Pro although I’m not sure if you could send MTP Control-F4. I think there is plans for a future release of MT Pro to have an outgoing action to close MTP.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:
1 Like

Scan code 121 on My PC is vk 183 which is Launch App2

1 Like