MTP with DaVinci Resolve using keystrokes

I am trying to get the transport keys working in DaVinci Resolve (edit mode) using a Behringer X-Touch controller. It should work using K, L, J, ShiftL and Up-Arrow for Stop, Forward, Backwards, FF and back-to-start respectively. This works using the keyboard.

I have written translation scripts that convert the relevant buttons on the X-Touch (HUI) into keystrokes, and according to the monitor screens they work. Also if I try them using 'Pages' I can see the correct characters being transmitted, and it works using Final Cut ProX. It works sometimes in Resolve, but then stops working...

I have tried using AppleScript, but Resolve won't accept it. I tried using delays (using key down, delay, key up) and that doesn't work any better (see screenshot)

I want to migrate from Final Cut to Resolve because of its seamless integration with the Fairlight DAW (which works fine with the X-Touch control surface). I can't be alone in this. Has anyone managed to get Resolve working successfully?


Attachments:
![](upload://mwXlOW1OzFQJklyuduRuYelcAEs.png)

Hi Keith,

Before we try to fix keystrokes (which will require Davinci resolve to be active to receive them), I suggest you set the MIDI mode for Mackie MCU Mode and try that instead as it would not need to have focus.

The following MCU notes with value of 127 will trigger the actions shown so you can set up MIDI translator to convert to these notes and if you are in Mackie Mode, Davinci Resolve would rather use them in this way.

91 – Rewind

92 – Fast Forward

93 – Stop

94 – Play

95 – Record

all on MIDI channel 1

Can you give that a try?

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist
bome@sniz.biz

I have also tried this in MCU mode just to be sure that doesn’t make any difference. Resolve will not accept MIDI in edit mode with the exception of volume sliders and pan pots. It will accept keystrokes translated by MTP for the jog wheel but is unreliable for anything else.

OK, interesting as the manual on page 2380 of the manual calls this out as a feature for transport control.
I’ll experiment further.

OK, I did notice it is working for me. I also noticed the behavior is slightly different depending on where you cursor is within Resolve (the bottom area or the left or right preview areas)

Within MT Pro I set all as “physical key”. I used down arrow instead of shift L.

I know you sad it works “sometimes” but then stops working. Maybe shut down some other apps and keep experimenting until it starts working again.

If I can duplicate the problem, I will get back to you. I’m on Mojave 10.14.6. What version of MacOS are you running?

 

Tried this – see comment above.

I’m running macOS Catalina 10.15.2.

I’ll try again on another machine, experiment as you suggest, and report back.

Keith

Did you set up accessibility on your Mac to allow the Bome MT Pro application to send keystrokes?

Yes. I also added it to ‘Input Monitoring’

Where do I allow MT pro to to send keystrokes ?
Where do I finde ‘Input Monitoring’ on My Imac ?

The outgoing action in MT Pro should be set up as a keystroke action. In MacOS you need to make sure you allow Bome MIDI Translator Pro to access accessibility features under the security settings.

I’m not sure but there I believe that there are programs that you can find to analyze incoming keystrokes. Try googling it. With that said, within MT Pro you can open the log Window and check “Outgoing”. However your target application will need to be focused for it to receive keystrokes and by default MT Pro will not send keystrokes if it is the focused application (primarily so you don’t mess up your project file, however you can change this behavior in settings if you would like.

Steve Caldwell
Bome Customer Care
Also available for paid consulting services: bome@sniz.biz

Thanks Steven
My problem is that Davinci Resolve only receives a combination keystrokes once in a while.
Sometimes Resolve can receive( com + keystroke or opt+keystroke) other times it cannot.
Sometimes I start Resove and then the combinations work and after some time it stops receiving from MT Pro.
Resolve is always able to receive direkt from the keyboard but then ignores MT Pro, out of the blue.
MT pro’s log shows that MT Pro works flawlessly.
So I stille is having this (Un)Resolve problem ;(
Thanks for a super operation safe MT Pro and always greate support.

Did you put a delay between keystrokes? This could be part of the issue is that maybe Resolve is quick enough to process them and depending on computer workload, sometime it is not.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

no delay

Show me a sample keystroke combination and I will show you how to add delays to make it more reliable.
EDIT : Oh I see you did provide an example. I’ll get back to you tomorrow, or you can search the forum for keystroke delay and I’m sure you can find and example. I’ve provided examples on this forum many times.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Thanks I will try the forum

Try this,
You may want to change the keystroke outgoing action as I did this on Windows platform and I believe your are using Mac. I’m using Control-K as the sequence so change the outgoing actions as appropriate for your situation. Make sure that on any “down” keystrokes you have enable repeat unchecked.

In this case, each outgoing action is delayed by an additional 100ms (as set in ga) in the rules.

Key-Sequence-w-delay-2021-03-24.bmtp (1.6 KB)

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Thanks
I´will try this