Multi-monitor mouse emulation 3,1,2

Hello, I have 3 monitors from left to right, they are marked in windows as 3,1,2, therefore point 0,0 would be monitor 1 at the top left. Monitor 3 has negative x values.


I am trying to go to a point on monitor 1 and it is impossible to always go to monitor 3. I have tried several options for global and relative, but I can't.

I have checked with other software the position of the mouse and the position taken by midi translator is correct, but then it does not go to the correct point.


Is it possible to fix this?


I just tested my 3 displays on my Windows 10 desktop. They are 3 across 1920x1080 each.

Everything looks OK either by choosing a given display or the global desktop.

Other programs might determine the desktop of the monitor to the left of the primary desktop has negative y coordinates.  The global desktop of Bome MIDI Translator does not work this way so for instance is your primary desktop is in the middle and you are on the global desktop and display 3 is to the left, other programs might interpret the Y coordinates as -1 to -1920.  So you might need to adjust your variables to all positive numbers if using the global desktop instead of the individual monitor number. 

A lot of this also might depend on your graphics card which might have set up your desktop as 1 large virtual monitor with negative coordinates.


In this example I have a button to push to center on the respective display (or the global desktop).  I then use knobs to move up and down, or left and right on the currently selected display (or global desktop)


I tested on Windows 10 with 3 displays but let me know if you are on a Mac and I can test there too (although just 2 displays).




I have tried to put the monitors in order within the Windows display settings and it works fine.
Thanks Steve

Glad you got it working!

Hi Steve, I thought it was fixed, but the problem persists. I send you a video to see exactly the problem.



I have done many tests to change the order of the monitors in windows, test that there were no negative coordinates and change the primary monitor.

The tests were done with global desktop.

I think the problem happens when the primary monitor is on the right and the monitor order is windows is not correlative.
To do a test with 2 monitors in the windows configuration you should put:
2 | 1
And that the primary monitor was 1.

I’ll take a look but my displays are 3, 2 , 1 in that order and my primary monitor is 2.

Maybe it is something with how your graphics card is configured. I heard that some graphics cards are set up to make multiple monitors look like on big monitor for gaming. Check your graphics card settings. I have an AMD Radeon HD 6670 (pretty old graphics card). I think that NVIDIA has their own app for advanced graphics card setup.

Another possibility is that you might need to minimize MT Pro before testing as I believe the default is to ignore keystrokes and mouse clicks if MT Pro is the currently active window. You can turn this off in settings. If you check "Outgoing" on the log, it will tell you if the message is being suppressed intentionally by MT Pro.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

I upload another video of another vertical configuration of 2 monitors.
I have activated Outgoing as you told me to see what bome does.
I have also tried minimized and it works the same.

The graphic is gtx1070 from nvidia. NVIDIA has an option called surround to join the screens as if it were one, but this option is turned off.

Changing the primary monitor works fine.


I found some strange behavior when positioning displays vertically and escalated the issue. I'm only able to duplicate the problem if my displays are vertical to eachother.

Please be patient while we evaluate further.


Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Hi, just posting to say thanks for this thread… I encountered this issue after rewiring my monitors. With the bottom monitor connected as #2 and set as primary, I got weird jumps with mouse movement, although it worked fine before. With the same monitor (bottom) connected as #1 and set as primary, it’s back to working great!