Mysterious ghost links

I’ve been getting tech support from Image Line about some old MIDI links in FL Studio that refuse to die.
But they aren’t too sure what’s up because this is strange. Spooky ghost links.
Even with a new copy of windows 10, some of my old links are still present in a fresh copy of FLS. It’s odd. But today they have up and disappeared. Then I thought to boot up MTP, and they appeared again.

So the only data I have on this issue is MTP running or not running. Something in my MTP project is forcing FLS to show links on the mixer that don’t exist. There are files in a certain spot on the computer that store the link data for FLS, and currently those folders are empty. There should be files with the port numbers in there, but there are no files. But the links are there in the FLS project. If I close MTP, restart FLS, the links are now there to stay. I think a computer restart is what makes them disappear again.

Also I made fresh links yesterday and they have disappeared on me. As if I never made them. There is no sign that I ever made these new links. I’ve never seen that happen before. There’s evil afoot.
These ghost links have no port assigned and no file to draw from, so I have no idea what could be causing this.

Hi,

I’m not sure what you mean by “links” are you talking about virtual MIDI ports? Could you show me some screen shots so I understand what you are saying? Are you running Bome Network Pro as well o you computer?

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like

I had said booting up MTP caused the links to appear, but today I noticed booting up MTP didn’t make them appear. Having it running *and plugging in my Novation Launch Control XL that made the difference between the links being there or not.

Right clicking a linkable knob shows the menu options for linking:
Before

When there is an existing link, either generic or global type, the check mark will exist:
After

All these ghost links have no port assigned. Clicking ‘Reset’ doesn’t remove them as it should.
No Port

Connecting the LC XL made these old links appear in the right click menu. Disconnecting it made them disappear. I am also missing the fresh batch of links I made two days ago. They just up and disappeared.
So I thought it was MTP causing this. Looks like either the device is storing something on board, or there is a registry key associated with it storing these old links or MTP is making FLS show these links but only when the controller is plugged in.

Novation has a new editor called ‘Novation Components’. I lost the old editor when my windows os got wiped. I’ve given Novation supreme crap for making me go through an online login gate to configure my own controller. But they won’t give me the old editor. So it’s a small chance maybe there is an online cloud connection with this editor connecting to the device that is downloading these links on device boot up. I doubt it, but it’s possible.

I am not running Bome’s Network Pro. Just MTP.

I didn’t think to try it without MTP running. So I booted up FLS and saw the links are not there. Then I plugged in the device without MTP running. And it does cause the links to appear. So it looks like MTP isn’t involved at all.

Hi, Since your we are using Bome MIDI Translator to handle all messages from and to your Launch Control XL instead of directly talking to the the controller, you need to set up your MIDI ports differently. Two applications cannot talk to the same MIDI port on Windows at a given time. This is a Windows Restriction.

I have set up FL studio as follows to define the MIDI ports as BMT 1 instead of Launch Control XL but have the controller still identified as a Launch Control XL type. This allows most of the native functions to act as a normal Launch Control XL (using MIDI thru in MT Pro) while using translators to do the MOD’s that you requested.

See the screen shot below:

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I can’t use the factory ‘controller type’ - Novation Launch Control XL.
When I first bought the unit, I found this out. It has two modes: factory and user.
Using the factory mode and setting it to that device type, it locks you into the setup Image Line has made, as described by nucleon here.

So it’s not bad, but since I want to do everything customized how I like it, I set it to ‘generic controller’ and set up everything in MTP, including knob input/output. Gave it it’s own dedicated virtual port, #3.
The big thing here is using mouse click macroes on the mixer because you can’t link those to a controller.
So all my buttons don’t output at all, but just click on things.

That was my first question about using MIDI buddy for mouse click macroes. To push mute/solo buttons on the mixer. Still works good. :slightly_smiling_face: I love that little buddy. Maybe I’ll have some cash to buy some custom changes for it, one at a time, someday soon.

I can configure what messages the unit sends, using Novations editor (Novation Componenets). I put each of the 8 user banks on a different channel, with the same cc numbers. Works good. Did that just yesterday to try and clear these old links from it, but that didn’t work.

But switching user banks is two handed. Hold down ‘user’ and choose the bank. I was thinking to stick with one user bank and use the watchdog timer method to switch MTP presets instead. So it’s a one handed task, as the unit is on my right side now. Don’t know; it’s an idea, but might be dumb.

I just found they had made a python script for it too, here.
It’s interesting, but don’t need it. Only need python for the Akai Fire fixes. Haven’t got to that yet.

Haven’t heard back from Novation yet. I will try overwriting those ghost links. I can put up with them if I have to, but links disappearing is a show stopper.

Interesting the FL Studio cannot do MIDI learn from MIDI CH 9-16. Also the only DAW that I know that doesn’t allow MIDI buttons for Mute and Solo. The Mute/Solo project file I gave you had it set to Factory 1 (which is MIDI CH 9). I changed it below allowing user one as long as the CC and note numbers don’t change on user one for your XL and only the MIDI CH number.

I also put a midi thru route so that you could MIDI learn and pass through knobs and sliders.

Solo-and-Mute-XL–2022-06-01.bmtp (5.0 KB)

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

I also have a project file that takes the Factory Template 1 Settings on the LC XL and converts it to Mackie MCU.

With this you can set your controller type to MCU mode in FL Studio. Set the ports to BMT 1 and then it appears to FL Studio like a MCU device. Solo, Mute and Record Arm work without needing to map anything. Also the faders work. Just haven’t got LED feedback quite right yet as not sure FL Studio is sending it back correctly.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like

Yup. Everybody knows that’s dumb. That was the first thing that had got me looking at MTP. If you remember it was the first thing I was asking about mouse click macroes, and so I ended up with MIDI Buddy. The original Launch Control was the controller I first set up with mute/solo button mouse clicks. Have used the same translators you had sent me ever since. Just copy/paste them, set the mouse click position and set the in/outs.

But in the meantime after replying here, I had figured it out. The factory template is the offender.
I have the controller disabled in the FLS MIDI settings. So I run everything it does through BMTP#3 virtual port (set as 27 in FLS). If you remember, I had a struggle with whether to have the knobs and buttons seperate, or just have everything run through MTP.

So I didn’t care to bother with whatever driver it was set to in FLS. But apparently it matters.
Even though it’s disabled, If I set it to ‘generic controller’ the old links disappear. Setting it back to factory makes them appear again, and they can’t be deleted as normal. So the device is storing them onboard and Image Line’s “controller support” I mentioned earlier is causing this. Actually your mention of it made me read that page again and see the words, ‘auto detect’. Leading me to find the culprit.

So I just have to set it to ‘generic controller’ (even though it’s disabled and doesn’t communicate with FLS at all), and the problem is solved, but it reverts back to the one I don’t want on every boot up (factory), so unfortunately I have to redo this setup every time. I just finished telling IL about it.
Also have been working on my MTP project, to reset all the links (because of this problem). So I have all fresh MTP presets and new links set up. All new mouse click macroes on the buttons. Everything done except the button lights; don’t even know if I will bother with that.

56 parameters X 6 user banks. 336 links, new inputs set, new outputs set, renamed, relinked in FLS. New positions for mouse clicks on my new FLS template. Been doing this for two days, and some other keyboard things. Don’t want to change it now.

I never use the factory mode and never will. I can’t stand it, or having these companies tell me how to use these things, when I prefer to customize it in MTP how I like. So that means you’ve been working hard helping me and I’ve been rejecting everything you’ve been doing. Sorry, feel bad about that. :worried:

MCU is good in FLS for transport controls. I use MCU for my NI S61 MKII. Have to redo that controller too. I’m going to make better data back ups from now on. My MTP project survived, but it’s a version from like a year ago.
Funny you mention MCU. I just got a Mackie mixer and of course it has some really bad design things on it too. I just can’t win.

OK, I guess now I’m glad I never invested in purchasing FLS.

So what I have now is a project file that if you use MCU mode can handle solo, mute, select and record arm using LCXL. The faders also work. The knob above the faders is for pan, and you can use the other two rows of knobs for anything you want. I send everything that uses MCU to BMT1 and everything else goes to BMT2 so you can MIDI learn BMT2 I guess. But if you don’t want to do that, I understand. Might be better to get what you’ve had working for a while and go with it instead of possibly introducing a whole other set of issues.

Don’t feel bad, I’m now getting a bit more versed at FL Studio and may be able to help others as well.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like

Ya well, they are very good at some things and very bad at others.
FLS is quite a unique thing. I got lucky with MTP, so I get the best of both worlds.
But sometimes there is a frustrating wrench in the cogs, that’s without logic and doesn’t need to exist.

I forgot about the record arm buttons. Ugh. The original Launch Control had an extra row of buttons. I remember that now. The newer controller doesn’t have the buttons for it.
Guess I could use watchdog timers for all this. Short press for mute (execute on release: 0 value), long press for solo (500ms or something). The upper row: short press to select a track and long press for its record arm. So I would have four rows squished into two. Hmm…

Ya, I don’t want to throw away everything I’ve already done. This is already like the third time having to set it up. Now I have the long task of lighting the buttons. This controller is a major pain in my bon bon.

The links have reappeared without the launch control xl being plugged in at all.
So its port doesn’t show in FLS, but the links are there.

I closed MTP and refreshed the MIDI devices. MTP is still enabled in its settings.
I’ve never seen that before. When MIDI devices are turned off, they disappear from the MIDI settings.
And they definitely don’t remain enabled.

I dunno man. This is strange 5. I’m in the twilight zone right now.
It’s one reason after another, but then evidence makes that reason not possible.

**EDIT
Oh, these ones I’m seeing now are legitimate links. Forgot that I converted them to the ‘per project’ type. But the devices staying enabled is still strange.

On windows, the associated BMT ports will still be there but will not send or receive anything if MT Pro is not running (on Windows). If you want the BMT ports to go away and not be seen by FL Studio, then you should turn the virtual ports off in MT Pro.

  1. Go to the edit menu and change number of virtual ports to 0.
  2. Close MT Pro

Then the virtual ports will no longer appear in FL studio.

It shouldn’t hurt have them always there and enabled as long as each virtual port has it’s own unique port number in FL Studio. Of course, if nothing is connected, then you will not be able to send data to or receive data from these virtual ports.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like

The LC XL MIDI driver entries disappear when unplugging the device. And the entries reset themselves to the factory setup when plugging it in, even though they are disabled. Since it is the only one controlling if there is the old links existing in the project or not, I will assume it is a unique thing.

The Traktor Kontrol S3 driver disappears too, when turning it off. So it seems to be just random, according to which devices are “supported” or not, or something. I dunno. Just thought to mention it.

Yes, the LC XL and Traktor Kontrol S3 represent physical devices and with no devices there, will disappear. In contrast Bome MIDI Virtual Ports are always available (at least on PC) unless you delete them by setting the number of Virtual Ports in Bome MIDI Translator to zero. They are still there but will not send or receive anything unless MT Pro is running.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz
1 Like

Oh, didn’t know that, my fault.

I’ve figured out another issue I was having, that I haven’t mentioned here but was reporting it to IL steady for the better part of a year. Not only were links disappearing and strange ghost links appearing, but the ‘omni’ per project links wouldn’t work at all on my dj controller. Omni links let you use the same link on any instance of the same plugin, and knows which knob is active by which instance of the plugin is focused.

So yesterday I was trying to fix this and noticing in the log window some strange entries coming back at me, but they also looked familiar:

Then it dawned on me. I remember an IL official forum post from like a year ago, where IL had done some work to fix a popular problem people were having. Something about all CC’s sent to channel 10, to help with omni something. I dunno, can’t find the post now.

Checked my MTP project and all my knobs were sending on channel 10. haha BINGO!
So I changed the channel, the port and CC numbers to ones that read clean like this:

Clean

Now all my omni links are working again, for the first time in a year.
Thought it was MTP at first because it wasn’t happening when MTP wasn’t running.
So I’m letting you know in case someone else has this problem. Tell them it’s probably channel 10, and to change the port number and possibly their cc numbers too.
I’m pretty happy with myself that I figured it out.

Interesting. I really don’t see any MIDI channel 10 message in either of your screen shots.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

The debug log? That doesn’t say. The output in MTP I had set at channel 10 for those particular virtual banks.
I have four banks on my mixer and had all the cc numbers stacked neatly to avoid conflicts.
Now they all send on channels 3 and some on 4, changed the MTP 3 port to 32. Watched the FLS debug log when tweaking the knobs to see if any of those names popped up and so avoided any cc number that had a name associated with it. It seems to be good now.

I’m not 100% it’s because of channel 10, but IL definitely did have a thing they did regarding channel 10. I’ve told them about this.

1 Like