No DAW option in Studio/Setup when using Cubase12 Pro = no transport contol

Hi Bomers

I realise that my issue has come up before, but after weeks of abortive attemps to get my NI S88 contoller keyboard to work as it once did, I am really desperate for a resolution.

I have done numerous driver installs, Komplete Kontrol updates, checked NIHost Integration & NI Hardware Services in ‘Services’, and think that I understand how to do the Studio/Setup in Cubase (ie + S88 and going to select DAWs in both the Midi in & out), but no DAW options are available.

Komplete Kontrol works as a standalone, but not within Cubase - ie the transport controls do not respond but I can at least select and play samples successfuly.

For the record, in the Control Panel/Uninstall page, ‘Bome virtual MIDI (1.89MB) can be seen, and in the Device Manager/SystemDevices there is an entry ’ Bome Virtual MIDI Emulator’ (Device working properly). I have exhausted all my ideas and am at my wits end.

What am I missing, please?


Hmm, are you using the Native Instruments Virtual Ports? If so, you should probably talk to them.

With that said, this is how I think they do it. This doesn’t seem like a question for a Bome end-user product such as Bome MIDI Translator Pro.

NI S88 → Komplete Kontrol → NI Virtual Port → CuBase

So you should point your DAW to the Virtual Port that NI exposes as an input device. I’m not sure what type of translation they do within Komplete Kontrol (BOME VIRTUAL MIDI EMULATOR?) so not sure what transport controls that the NI S88 sends and what they are translated do with Komplete Kontrol to work with your DAW.

It would be important the Cubase is only looking to the NI Virtual Port for both input and output as if both your DAW and Komplete Kontrol are trying to access the NI-88 Hardware port, it will not work.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Many thanks Steve. I am in conversation with NI, but I’m not getting very far.
I have had it working in the past, but the DAW Midi IN and Out are now not showing as an option and without the ability to chose them, I am rather stuffed.
ie the transport buttons on the S88 cannot control anything.


Yes, I wish I knew more about how NI puts things together but without any of their gear, it would be hard to figure it out. I DO know that they license Bome MIDI Ports as part of their product but from there it is entirely up to them how to implement it. If it is anything like MT Pro, the software should generate the virtual ports on install. As far as translation, that would be the next step after getting connectivity. I’m not sure if they have anything to translates from what the S88 sends to what Cubase expects. I’m not even familiar with the device selection type that Cubase uses. I generally use Mackie MCU when using Cubase with my controllers and the protocol there is pretty well defined.

I think if I were you, I would probably do what you did and de-install and then re-install everything. Then start up Cubase and pray to see the virtual ports there. Then once you have connectivity work on whatever translation needs to happen between the s88 using whatever tools NI provides to do that.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Just a though, you might want to ask Steinberg (the Cubase people) if there is any magic on their side on re-polling available MIDI ports to see if doing something like that helps the virtual ports to show up again. They might have some soft of MIDI configuration file that you can delete which when deleted forces Cubase to regenerate it from currently available ports.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Many thanks. Uninstalling and reinstalling the required programmes does no seem to help, but I will contact Steinberg about the refresh of midi ports.

a side question: can you see the NI / S88 ports in other MIDI software, e.g. Send SX?

Hi Florian
Many thanks for your response. (I hope I interpretted your suggestion correcty…)

I downloaded the SendSX and found that the DAW virtual ports did not show. (see screen printy att.) I did not expect them to as the main issue of the Bome programme being greyed out in Device manager clearly shows that it is not properly loaded or maybe it has been blocked? I have uninstalled/reinstalled so many times but without success. It has worked in the past, but it was a long time ago.

Cheers Keith

Oh, I didn’t know that the respective devices are greyed out in Device Manager.
Have you tried the “Force reinstalling…” option in the Bome Virtual MIDI driver (BMIDI_Driver_2.1.0.44.exe)?

In Device Manager, if you invoke the properties of such a Bome virtual port, what does it show?

Here is an example of the Driver page for my “BMT 1” port.

Thank you again. I feel like I have finally found someone who understands.
Screen print att. showing Proprties. You can see that its not connected and the ‘forcing’ did not work.

This is very curious.
Are there any active Bome virtual ports at all?

In Device Manager, System category, is the “Bome Virtual MIDI Enumerator” running?

The Komplete Kontrol -1 and Komplete Kontrol EXT -1 are my only options when setting up my Cubase Studio/Setup for the S88. Thre ‘Enumerator’ looks OK in the Device Manager.

I worry that all my reinstalling etc over the past few weeks has made things worse - I don’t know if the fact that my S88 displays go black after a minute or two is connected to ther issue, but the whole system has become very flakely! (can still use the S88 as a MIDI keyboard once I managed to choose a voice from the NI browser). In ‘Services’ the two NI entries are Auto and Running OK

I’ve tried installing your ‘Translator’ to get the Virtual ports from another ‘source’ but no change there! I’ve also ensured that there are no power management issues in the USB department. I have a remote session next week with a NI guy. I am hoping for the best, but I’m beginning to feel that it is a lost cause.



I think I would just delete the devices within Device Manager and then force re-install the drivers.
If I remember, sometimes if the device shows incorrectly a force re-install of the drivers doesn’t seem to fix anything.

The only time I’ve had problems like this is when I installed Copper Lan on my system which played havoc with my MIDI ports. Nothing else on the system would see them.

Steve Caldwell
Bome Customer Care

Also available for paid consulting services:

Thank you Steve, but despite hours spent trying, and ‘forcing’ the re-installs I still have no DAW control. (NI Komplete Kontrol/S88 works OK as a standalone). I haven’t heard of Copper Lan, but I’ll stear clear of it if ever I get this working again.
In the meantime, Agh…!