No Output On Preset Still Outputs

Hi, how come when I create an alias for a preset and set it to ‘none don’t ask again’, to make sure the output for that preset is mouse clicks only, FL Studio is still getting a signal from MTP?
I’ve divided my buttons into their own dedicated presets to avoid this. It annoys me to no end. Is there a way to actually have no MIDI output when I set the preset port to have no output?

I’d have to look at the project file to see what is happening.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Here.
TJ MB Project.bmtp (1.5 MB)

In this case it’s the Novation Launch Control XL presets. Near the bottom.
I divided the presets into knob and buttons. The knob presets have an output port so FL Studio can pick it up and link to knobs in it. The buttons just do mouse clicks, so I don’t need it outputting to FLS. Seeing the MIDI icon blinking every time I push a button drives me up the wall.

On the button presets’ input I have the MIDI controller enabled and also virtual in #2. That’s the output port for MIDI Buddy, so it can feed the presets that need it. I assume that’s how it works.

So recently I’ve been using my Launch Control XL again. But now with every session I’ve used it or not used it the last time, I’m getting that project warning to select ports. And MIDI buddy is telling me the output ports have changed. NO they HAVEN’T! The only difference is if that controller was used or not.

I’m getting real sick and tired of that already.

Hi,

  1. In your project file, create an alias called “My Launch Control” or something similar. Then assign it to Launch Control XL (or whatever your Launch Control XL reports as the physical device).
  2. Then go through all your translators and/or presets that use your launch control XL and direct the inputs from your newly defined alias in step 1 above.

After that, your project file should prompt you for the alias “My Launch Control” if it is not defined. If you have it connected it should find it. If it is not connect, you should be able to pick “don’t ask again” and it will not prompt you again. Of course at that point if you add it back in, you will need to use MIDI → Edit Port aliases again to assign it.

The current name Launch Control XL is not an alias but the actual physical port but when you don’t have it connected when MT Pro doesn’t see it, and you have port names with that same name, it assumes it is an alias that needs assignment.

My recommendation is you do your assignments this way for all of your ports. For instances Bome MIDI Translator 4 out I would assign the alias “FL Studio”. I would assign Bome MIDI Translator 2 Virtual in the alias “MIDIBuddy”, etc. That way if your configuration changes, you don’t have to go through the pain of re-assigning as many things if your configuration changes around.

When MIDI Buddy starts, it compares the Windows assigned Port Number (ie “1”) to the port name (ie Launch Control XL). If the port number assigned to port 1 has changed (like you plugged it a different configuration of MIDI controllers), then MIDIBuddy will assume you have changed things around and prompt you to re-assign it. It only does this if your MIDI port configurations have changed since the last time it launched (by adding o subtracting any MIDI ports (virtual or physical) . This is a safety precaution to make sure as you move controllers around, that your keep the correct port assigned to MIDIBUDDY.

As long as MIDIBuddy starts and the Windows assigned port number that you are using for MIDIBuddy doesn’t change, you should not prompt you. I know your assignment to the port name may not have changed, however it is prompting you because Windows may have assigned a new port number.

After you fix aliases as suggested. If you turn on “Outgoing” on the log window while you are getting unwanted output to FLS, then we can look at your log to find the offending translator number that is sending output to FLS.

I hope this helps!

Steve

1 Like

Ok awesome.
I actually removed the presets from using port 2 as a MIDI Buddy incoming port. So MB outputs at port 2 but I don’t have anything dedicated to monitoring port 2, but it’s still working as before. They seem to be able to get the mouse position anyway.

I will use aliases if I keep running into the port pop up issue, thank you!

Hmm, if you getting mouse positions from MIDIBuddy, you must be using other than port two.

Steve Caldwell
Bome Customer Care


Also available for paid consulting services: bome@sniz.biz

Ya, I don’t know how it works, but I’ve never set up any incoming port of MB before, until recently. It’s always just worked as is. I decided to give it it’s own port (2), having all my MIDI controllers having their own dedicated virtual ports. The mouse translators seem to work fine without setting up an incoming port 2 on anything.